Hi,

I successfully built the Sourceforge pyOpenSSL project with mingw32.

But I'm on a 64-bit machine and have had problems with loading the project's DLLs at runtime (on a 32 bit machine loading the DLLs works fine) and when I found mingw-64 on sourceforge thought I'd give it a try and see if it helped me out on my 64 bit machine.  The code will eventually need to be deployed on 64 bit machines.

Downloaded a recent toolchain build.  The instructions I used are here: 

http://mingw-w64.wiki.sourceforge.net/Installation+of+binary+toolchain+packages

So I can copy the whole of the toolchain directory structure to any directory location; add the bin directory within the toolchain to my PATH; and at least according to the instructions above I should be good to go.

Yeah right.

The compile quickly exits with:

L:\MyID\Python\pyOpenSSL>setup.py build_ext -Ic:\openssl\include -c x86_64-pc-mingw32
running build_ext
error: don't know how to compile C/C++ code on platform 'nt' with 'x86_64-pc-mingw32' compiler
Looking around the web, I believe x86_64-pc-mingw32 to be the correct name to be use.  However when I look under where I installed mingw64, I find 3 bin directories:
pat$ pwd
/cygdrive/d/mingw64
pat$ find . -name bin
./bin
./mingw/bin
./x86_64-pc-mingw32/bin
pat$
I originally set the location in PATH to the first of the 3.  Didn't work.  And then I tried #s 2 and 3 and they provoked exactly the same error from the build.

pat