Hi all,

I am running MinGW-4.5.0 and MSYS 1.0.14 on Windows 7 x64. I recently
installed XSD on to my system and decided to run through and make all of its
examples under MSYS.

However, when I got to one of the examples I encountered a strange error
where it appears that MSYS (I presume) performed some unnecessary string
substitution and changed one of the arguments passed to a program from
--custom-type anyType=/type_base to --custom-type anyType=C:/msys/1.0.
Needless to say the makefile soon crashes out under the multitude of errors
thay ensue from this.

I posted to the XSD mailing list to see if they had any answers to this and
they suggested that I try adding single quotes around the term or escaping
the / to try and get around it. I tried both and then both together, I also
tried using double quotes.

Regardless of which one I tried I was still met with errors. With just the
single/double quotes around it the result is exactly the same. If I escaped
the / either with or without the single/double quotes the result was changed
from C;/msys/1.0 to just \

I tried googling this, but found nothing.

Is this a bug? Or is it one of those things that is acting the way it should
be, but just not in my case?

Regards
Bidski