On 27.07.2012 3:06, Mark Mikofski wrote:
> On Wednesday, July 25, 2012 2:11 PM, LRN wrote:
>> On 25.07.2012 23:47, Mark Mikofski wrote:
>>> Problem: libxslt always looks for libiconv in /usr/lib instead
>>>  of /mingw/lib
>>> Overview: I am trying to build libxslt for win32 with mingw
>>> (gcc 4.7) and using the native mingw libraries for libxml2,
>>> zlib and iconv. I can download precomiled binaries fro xmlsoft,
>>> but libxslt from xmlsoft doesn't find libiconv.dll on $PATH
>>> (.:/usr/local/bin:/mingw/bin:/bin) maybe because in /mingw/bin
>>> it's named libiconv-2.dll and in /bin it's named
>>> msys-iconv-2.dll. So you can download their iconv, xml2,
>>> xmlsec, zlib, etc, - that's what I did as a workaround, and put
>>> it in /opt which I can add to $PATH. But I would rather just
>>> rebuild xslt.
>>> Methods: 1. edit configure to add -f to RM since it throws an
>>> error, "can't delete libtoolT" on lines containing "RM
>>> $(ofile)T" 2. from msys shell ./configure --without-python
>>> --without-crypto 3. make libtool: link: returns the error,
>>> "/usr/lib/libiconv.la is not a valid archive"
>>> I tried various ways of overriding the library
>>> --with-libxml-libs-prefix='-L/usr/lib -lxml2 -L/mingw/lib
>>> -liconv' LIBXML_LIBS='-L/usr/lib -lxml2 -L/mingw/lib -liconv' I
>>> also tried LDFLAGS, but no matter what it always looks for
>>> libiconv.la in /usr/bin.
>> Tried --with-iconv-prefix or --with-libiconv-prefix ?
> I checked the configure file and there is no explicit option
> --with-iconv-prefix or --with-libiconv-prefix, or any variant,
> although there is a generic --with-PACKAGE=[args] option.
> Nevertheless, I tried --with-* options you suggested and configure
>  states "unrecognized options" and still has the variables
> LIBXML_LIBS, etc. set to look for libz, libiconv and libm in
> /usr/lib, and not /mingw/lib.
> Although you gave me an idea; I tried:
> $ ./configure --without-python --without-crypto
> --with-libxml-libs-prefix=/mingw/lib
> --with-libxml-include-prefix=/mingw/include
> which added -L/mingw/lib to the the libtool --mode=link command
> during make, but I **still** get the exact same error
Ok, another stupid question: have you tried configuring libxslt with
the --prefix=/mingw argument?
Thanks, so I didn't want to install libxslt in /mingw, I wanted to install in /usr/local so I left prefix as default. But see my other thread about mbstate_t and nano, when I installed the msys-libiconv library, this problem went away, because now iconv.h *is* in /usr/lib.

*So* I was finally able to build libxslt just usig --without-python and --without-crypto, make and install. Done!