#97 make doesn't work.

OTHER
closed
nobody
binutils (105)
duplicate
Duplicate
2013-01-31
2001-12-11
Anonymous
No

The Makefile given below works well with Cygwin's make
while MinGW shows the following error-message:

MinGW_make: *** No rule to make target `make_test.a
(make_test.o)', needed by `make_test.a'. Stop.

both make.exe are GNU Make Version 3.79.1

Copy of the Makefile:

# EXECUTABLE NAME(S) GIVEN BELOW
EXEFILE = make_test

# TARGETLIBRARY NAME GIVEN BELOW
TARGETLIB= make_test.a

# OBJECTS GIVEN BELOW
OBJMAIN = make_test.o
OBJS= $(TARGETLIB)($(OBJMAIN))

#------------------------------------------

$(EXEFILE): $(TARGETLIB)
$(AR) -x $(TARGETLIB) $(OBJMAIN)
$(CC) -o $@ $(OBJMAIN) $(TARGETLIB)
$(RM) $(OBJMAIN)

$(TARGETLIB): $(OBJS)
@echo library $(TARGETLIB) is now up-to-date

Discussion

  • Danny Smith

    Danny Smith - 2001-12-11
    • status: open --> closed-duplicate
     
  • Danny Smith

    Danny Smith - 2001-12-11

    Logged In: YES
    user_id=11494

    duplicate of 491549

     
  • Earnie Boyd

    Earnie Boyd - 2013-01-31
    • status: closed-duplicate --> closed
    • resolution: --> duplicate
    • category: --> Known_bugs
    • milestone: --> OTHER
     
  • Earnie Boyd

    Earnie Boyd - 2013-01-31
    • category: Known_bugs --> Duplicate
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks