#884 returning before link is finished (ld running in background)

OTHER
closed
nobody
binutils (105)
works-for-me
Unknown
2014-08-27
2005-12-23
No

I have been working with Gtk and when working by hand,
it usually doesn't matter, but when creating a long
script to generate an installer, the linker because
very annoying.

I have the same effect with gcc 3.2.x and 3.4.x

What happens is that the linker returns before it is
finished. So I get a prompt back and that means I'm
supposed to be able to do more work and that my
executable is finished. Not the case, the executable is
still being worked on.

I put my output below. You can see that I get my prompt
back (Helene1@HELENE) before to get a list of "Info:
resolving blah by linking to blah"

I know that gcc will run processes one after another,
I'm not aware of it running them in a background
process. Right now it looks like that is what is happening.

If you have any quick solution, let me know. I can't
give you this very code, but I should be able to create
a small sample to show the problem if you need.

Thank you,
Alexis Wilke

Helene1@HELENE
/d/AllDev/TurnWatcher/BUILD/home/turnwatcher/turnwatcher/src
$ make
/bin/sh ../libtool --tag=CXX --mode=link g++
-mno-cygwin -mwindows -mms-bitfiel ds
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/mo
-ID:/AllDev/TurnWatcher/BUILD/
mingw/include/libpng12
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/gdkmm-2.4
-ID
:/AllDev/TurnWatcher/BUILD/mingw/lib/gdkmm-2.4/include
-ID:/AllDev/TurnWatcher/B
UILD/mingw/include/glibmm-2.4
-ID:/AllDev/TurnWatcher/BUILD/mingw/lib/glibmm-2.4
/include
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/pangomm-1.4
-ID:/AllDev/Tur
nWatcher/BUILD/mingw/include/gtk-2.0
-ID:/AllDev/TurnWatcher/BUILD/mingw/lib/gtk
-2.0/include
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/sigc++-2.0
-ID:/AllDev/
TurnWatcher/BUILD/mingw/lib/sigc++-2.0/include
-ID:/AllDev/TurnWatcher/BUILD/min
gw/include/glib-2.0
-ID:/AllDev/TurnWatcher/BUILD/mingw/lib/glib-2.0/include
-ID
:/AllDev/TurnWatcher/BUILD/mingw/include/pango-1.0
-I/home/ivan/cross/build/incl ude/cairo
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/cairo
-ID:/AllDev/TurnWatc
her/BUILD/mingw/include/gtkmm-2.4
-ID:/AllDev/TurnWatcher/BUILD/mingw/lib/gtkmm-
2.4/include
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/atkmm-1.6
-ID:/AllDev/Tu
rnWatcher/BUILD/mingw/include/atk-1.0
-Wl,--enable-runtime-pseudo-reloc -LD:/
AllDev/TurnWatcher/BUILD/mingw/lib -lmo -ljpeg -ltiff
-lpng12 -lz -lgtkmm-2.4 -l gdkmm-2.4
-latkmm-1.6 -lgtk-win32-2.0 -lpangomm-1.4 -lglibmm-2.4
-lsigc-2.0 -lgd k-win32-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lpangowin32-1.0 -lgdi32
-lpangocairo-1.0 -lpango-1.0 -lcairo
-lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv
-l z -lregex -lmsimg32 -lshfolder
-lshell32 -o TurnWatcher.exe -Wl,--enable-runtim
e-pseudo-reloc
-LD:/AllDev/TurnWatcher/BUILD/mingw/lib -lmo -ljpeg
-ltiff -lpng1 2 -lz -lgtkmm-2.4
-lgdkmm-2.4 -latkmm-1.6 -lgtk-win32-2.0 -lpangomm-1.4
-lglibmm -2.4 -lsigc-2.0
-lgdk-win32-2.0 -latk-1.0 -lgdk_pixbuf-2.0
-lpangowin32-1.0 -lgd i32
-lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
-lgmodule-2.0 -lglib-2.0 -lintl
-liconv -lz -lregex -lmsimg32 -lshfolder -lshell32
common.o actionMana ger.o uiBase.o
character.o CharacterListUI.o MainWindow.o
TurnWatcher.o initiati ve_manager.o
EditWindow.o JumpInWindow.o DamageWindow.o
AboutWindow.o splash.o r esources.o
g++ -mno-cygwin -mwindows -mms-bitfields
-ID:/AllDev/TurnWatcher/BUILD/mingw/inc
lude/mo
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/libpng12
-ID:/AllDev/TurnWat
cher/BUILD/mingw/include/gdkmm-2.4
-ID:/AllDev/TurnWatcher/BUILD/mingw/lib/gdkmm
-2.4/include
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/glibmm-2.4
-ID:/AllDev/
TurnWatcher/BUILD/mingw/lib/glibmm-2.4/include
-ID:/AllDev/TurnWatcher/BUILD/min
gw/include/pangomm-1.4
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/gtk-2.0
-ID:/
AllDev/TurnWatcher/BUILD/mingw/lib/gtk-2.0/include
-ID:/AllDev/TurnWatcher/BUILD
/mingw/include/sigc++-2.0
-ID:/AllDev/TurnWatcher/BUILD/mingw/lib/sigc++-2.0/inc
lude
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/glib-2.0
-ID:/AllDev/TurnWatche
r/BUILD/mingw/lib/glib-2.0/include
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/p
ango-1.0 -I/home/ivan/cross/build/include/cairo
-ID:/AllDev/TurnWatcher/BUILD/mi
ngw/include/cairo
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/gtkmm-2.4
-ID:/All
Dev/TurnWatcher/BUILD/mingw/lib/gtkmm-2.4/include
-ID:/AllDev/TurnWatcher/BUILD/
mingw/include/atkmm-1.6
-ID:/AllDev/TurnWatcher/BUILD/mingw/include/atk-1.0
-Wl, --enable-runtime-pseudo-reloc -o
TurnWatcher.exe -Wl,--enable-runtime-pseudo-rel
oc common.o actionManager.o uiBase.o
character.o CharacterListUI.o MainWindow.o
TurnWatcher.o initiative_manager.o EditWindow.o
JumpInWindow.o DamageWindow.o Ab
outWindow.o splash.o resources.o
-LD:/AllDev/TurnWatcher/BUILD/mingw/lib /mingw
/lib/libmo.a -lltdl -ljpeg -ltiff -lpng12
-lgtkmm-2.4 -lgdkmm-2.4 -latkmm-1.6 -l
gtk-win32-2.0 -lpangomm-1.4 -lglibmm-2.4 -lsigc-2.0
-lgdk-win32-2.0 -latk-1.0 -l
gdk_pixbuf-2.0 -lpangowin32-1.0 -lgdi32
-lpangocairo-1.0 -lpango-1.0 -lcairo -lg
object-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv
-lz -lregex -lmsimg32 -lshfol der -lshell32

Helene1@HELENE
/d/AllDev/TurnWatcher/BUILD/home/turnwatcher/turnwatcher/src
$ Info: resolving __ZN3Gtk5Stock4OPENE by linking to
__imp___ZN3Gtk5Stock4OPENE (auto-import)
Info: resolving __ZN3Gtk5Stock6CANCELE by linking to
__imp___ZN3Gtk5Stock6CANCEL E (auto-import)
Info: resolving __ZN3Gtk5Stock4SAVEE by linking to
__imp___ZN3Gtk5Stock4SAVEE (a uto-import)
Info: resolving __ZN3Gtk5Stock5CLEARE by linking to
__imp___ZN3Gtk5Stock5CLEARE (auto-import)
Info: resolving __ZN3Gtk5Stock4QUITE by linking to
__imp___ZN3Gtk5Stock4QUITE (a uto-import)
Info: resolving __ZN3Gtk5Stock4UNDOE by linking to
__imp___ZN3Gtk5Stock4UNDOE (a uto-import)
Info: resolving __ZN3Gtk5Stock4REDOE by linking to
__imp___ZN3Gtk5Stock4REDOE (a uto-import)
Info: resolving __ZN3Gtk5Stock10MEDIA_PLAYE by linking
to __imp___ZN3Gtk5Stock10 MEDIA_PLAYE
(auto-import)
Info: resolving __ZN3Gtk5Stock10MEDIA_STOPE by linking
to __imp___ZN3Gtk5Stock10 MEDIA_STOPE
(auto-import)
Info: resolving __ZN3Gtk5Stock10MEDIA_NEXTE by linking
to __imp___ZN3Gtk5Stock10 MEDIA_NEXTE
(auto-import)
Info: resolving __ZN3Gtk5Stock7JUMP_TOE by linking to
__imp___ZN3Gtk5Stock7JUMP_ TOE
(auto-import)
Info: resolving __ZN3Gtk5Stock4HELPE by linking to
__imp___ZN3Gtk5Stock4HELPE (a uto-import)
Info: resolving __ZN3Gtk5Stock2OKE by linking to
__imp___ZN3Gtk5Stock2OKE (auto- import)
Info: resolving __ZTTN3Gtk14TreeViewColumnE by linking
to __imp___ZTTN3Gtk14Tree ViewColumnE
(auto-import)
Info: resolving __ZTVN3Gtk14TreeViewColumnE by linking
to __imp___ZTVN3Gtk14Tree ViewColumnE
(auto-import)
D:/AllDev/TurnWatcher/BUILD/mingw/lib/libstdc++.a(eh_throw.o)(.text+0xfa):eh_thr
ow.cc: undefined reference to
`_Unwind_SjLj_Resume_or_Rethrow'
$

Discussion

  • Danny Smith

    Danny Smith - 2006-09-05
    • assigned_to: dannysmith --> nobody
     
  • Danny Smith

    Danny Smith - 2006-09-05

    Logged In: YES
    user_id=11494

    I can't reproduce this. If you do have a reprodicible
    testcase I will look at it.

    Danny

     
  • Alexis Wilke

    Alexis Wilke - 2006-12-05

    Logged In: YES
    user_id=554061
    Originator: YES

    Hi Danny,

    I finally came back to this one... and now my scripts are running just fine. No need for a pause or anything like that.

    I'm not too sure what was happening before, but the shell was started from a telnet of my own whereas now I use sshd from cygwin to start the MSYS shell. So maybe something to do with the initialization of the new process.

    Also, it could be that the newer version of MSYS fixed the problem! 8-)

    Thank you,
    Alexis

     
  • Alexis Wilke

    Alexis Wilke - 2006-12-05
    • status: open --> closed-works-for-me
     
  • Earnie Boyd

    Earnie Boyd - 2013-01-31
    • labels: ld --> binutils
    • status: closed-works-for-me --> closed
    • resolution: --> works-for-me
    • category: --> Unknown
    • milestone: component_package --> OTHER
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks