#646 memory leak

OTHER
closed
gcc (462)
wont-fix
Known_bugs
2013-01-22
2004-09-05
h_ayguen
No

environment is:
OS:Windows 2000 SP4
gcc.exe (GCC) 3.4.1 (mingw special)
GNU ld version 2.15.90 20040222
MINGW32_NT-5.0 HIGHSCREEN 1.0.10(0.46/3/2) 2004-03-15
07:17 i686 unknown
mingw runtime version __MINGW32_VERSION 3.1
win32 api version __W32API_VERSION 2.5

the error is that in the package:
gcc-core-3.4.1-20040711-1-src.tar.gz
in detail in file
w32-shared-ptr.c:160
in function __w32_sharedptr_initialize ()
called from function __do_global_ctors ()
60 bytes of memory get allocated which are not freed at
exit of this program.

this is fatal cause i link in a malloc() replacement
which looks for memory leaks. now at exit of any
program this library asserts with

>./eftest
>
>Electric Fence 2.4.10
>Copyright (C) 1987-1999 Bruce Perens <bruce@perens.com>
>Copyright (C) 2002-2004 Hayati Ayguen
<hayati.ayguen@epost.de>, Procitec GmbH
>
>Electric Fence: ptr=0x4b1fc4 size=60 alloced from
UNKNOWN (use #include "efence.h")(0) not freed
>ElectricFence Aborting:
>Electric Fence: EF_delFrame(): Found non free'd pointers.
>
>abnormal program termination

for that library see
http://www.pf-lug.de/projekte/haya/efence.php
the test program reproducing this error contains not
more than an empty main():

int main()
{
return 0;
}

i'm unsure if i may turn that call to malloc in
w32-shared-ptr.c:160 into a piece of static/global memory?

Discussion

  • h_ayguen

    h_ayguen - 2007-07-30

    Logged In: YES
    user_id=1354765
    Originator: NO

    Hello,

    one or two months ago someone asked if this problem is still there.

    meanwhile i reinstalled MinGW 5.1.3 and tried with upcoming duma 2.5.4, which will be downloadable from http://sourceforge.net/projects/duma.

    call "mingw32-make OSTYPE=msys" from Windows command prompt
    having added the PATH for MINGW/bin

    i did not debug .. but the memory leak is still there.
    the installed compiler version was "gcc (GCC) 3.4.2 (mingw-special)"
    after installing "gcc (GCC) 3.4.5 (mingw special)" the result was the same.

     
  • Danny Smith

    Danny Smith - 2007-07-31

    Logged In: YES
    user_id=11494
    Originator: NO

    Won't fix in 3.4 series.
    Not a bug in 4.x series since _w32_sharedptr_initialize () is gone

    Danny

     
  • Danny Smith

    Danny Smith - 2007-07-31
    • status: open --> closed-wont-fix
     
  • Earnie Boyd

    Earnie Boyd - 2013-01-22
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,4 +1,3 @@
    -
     environment is:
     OS:Windows 2000 SP4
     gcc.exe \(GCC\) 3.4.1 \(mingw special\)
    
    • status: closed-wont-fix --> closed
    • resolution: --> wont-fix
    • category: --> Known_bugs
    • milestone: Known_bugs --> OTHER
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks