#51 gcc installation problem - tcsh

Known_bugs
closed-fixed
nobody
gcc (462)
2001-07-30
2001-06-29
No

This is a new bug which has shown itself in the
current MinGW-1.0 release.

When using tcsh.exe from
ftp://ftp.blarg.net/users/amol/tcsh/
'gcc -v' returns the following:

Using builtin specs.
gcc version 2.95.3-4 (mingw special)

When a compile is attempted, it fails because it cannot
find
the cpp0 program.

However, this works perfectly when using 'cmd.exe' or
'sh.exe' as the shell.

The previous release (gcc-2.95.2) worked perfectly.

Discussion

  • Danny Smith

    Danny Smith - 2001-06-30

    Logged In: YES
    user_id=11494

    Thanks for the report.
    Yes, I've just confirmed this on NT4, using Amol's tcsh.
    zsh also causes this problem.

    This fixes for me:
    download and install the patched gcc drivers
    (gcc-2.95.3-20010613-W95patch.tar.gz)
    These use '\\' rather '/' as primary dir separator.

    Danny

     
  • Luigi Mancinelli

    Logged In: YES
    user_id=279884

    I have the same problem with sh.exe and command.com
    and windows 98

     
  • Paul Garceau

    Paul Garceau - 2001-07-25
    • milestone: --> Known_bugs
     
  • Paul Garceau

    Paul Garceau - 2001-07-25

    Logged In: YES
    user_id=1762

    Possible that original was built with Win95 using command.exe.

     
  • Paul Garceau

    Paul Garceau - 2001-07-25
    • status: open --> open-accepted
     
  • Danny Smith

    Danny Smith - 2001-07-30

    Logged In: YES
    user_id=11494

    zsh, tcsh, bash do not cause problems with latest gcc-
    2.95.3-5 (mingw special). Nor with the 2.95.3-4 with
    w95patch.

     
  • Danny Smith

    Danny Smith - 2001-07-30
    • status: open-accepted --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks