#460 bash changes part of environment to upper case

MSYS
closed
None
rejected
Known_Feature
2013-01-25
2003-11-26
Olaf Flebbe
No

Hi,

-- msys 1.0.9 on w2k

the bash supplied by msys 1.0.9 converts the first part
of the environment (the thingy before the letter =) to
upper case.

I know that the environment is case insensitive on
Windows, but it should be case preserving.

A demonstration:

compile b.c to b.exe (tested with both current mingw
and vc.net), download b.sh
------------ b.c -----------
#include <stdlib.h>
main() {
putenv("TTtt=test");
system("sh b.sh");
}
------------- b.sh -----------
echo "TTtt=$TTtt, TTTT=$TTTT"
------------------------------

running b the output is
TTtt=, TTTT=test
but IMHO it should be (on Windows)
TTtt=test, TTTT=test

(as a side note, on unix I would expect
TTtt=test, TTTT= )

This misfeature is a major showstopper in a bigger
development package I would like to use.

I am not sure if bash itself is causing the trouble...

Discussion

  • Earnie Boyd

    Earnie Boyd - 2003-11-27

    Logged In: YES
    user_id=15438

    Try your tests with the MSYS-1.0.10 release candidate.

    Earnie

     
  • Olaf Flebbe

    Olaf Flebbe - 2003-11-27

    Logged In: YES
    user_id=88929

    Verified it with the 1.0.10rc2 candidate.

    Found the root Cause of the problem. It is in the msys build
    environment

    msys/rt/src/winsup/cygwin/environ.cc function

    ucenv (line 363) used for the first initial shell.

    Could you please supply a recent msysDVLPR package because
    it msys does not compile out of the box?

     
  • Earnie Boyd

    Earnie Boyd - 2005-05-03

    Logged In: YES
    user_id=15438

    I now know that this was purposeful. If you a demonstration
    of a patch to not change the variable name to uppercase does
    not cause harm to many project builds I would reconsider.

    Earnie

     
  • Earnie Boyd

    Earnie Boyd - 2005-05-03
    • status: open --> closed-rejected
     
  • Earnie Boyd

    Earnie Boyd - 2013-01-25
    • labels: MSYS -->
    • status: closed-rejected --> closed
    • resolution: --> rejected
    • category: --> Known_Feature
    • milestone: --> MSYS
     

Log in to post a comment.