SourceForge has been redesigned. Learn more.
Close

#423 cstdlib won't compile

OTHER
closed
duplicate
Duplicate
2013-01-31
2003-09-10
No

I wrote a simple C++ program that makes some little
output and uses std::string. The sources do not
compile, because g++ tells me, that a declaration in
cstdlib is wrong:

C:/PROGRA~1/MINGW/MINGW/include/c++/3.2.3/cstdlib:139:
`_Exit' not declared
C:/PROGRA~1/MINGW/MINGW/include/c++/3.2.3/cstdlib:165:
`_Exit' not declared

The corresponding lines are:

namespace __gnu_cxx
{
using ::lldiv_t;
using ::_Exit;
//...
}

and

namespace std
{
using __gnu_cxx::lldiv_t;
using __gnu_cxx::_Exit;
//...
}

The declaration of _Exit comes from stdlib.h and is
only used if __NO_ISOCEXT is not defined (ll 411).

I'm using MinGW 3.2.3 20030504.

Discussion

  • Earnie Boyd

    Earnie Boyd - 2003-09-11

    Logged In: YES
    user_id=15438

    It would be nice to have your ``simple program''.

     
  • Earnie Boyd

    Earnie Boyd - 2003-09-11
    • assigned_to: earnie --> dannysmith
     
  • Danny Smith

    Danny Smith - 2003-09-12
    • status: open --> closed-duplicate
     
  • Danny Smith

    Danny Smith - 2003-09-12

    Logged In: YES
    user_id=11494

    Duplicate of 738146
    Danny

     
  • Robert Bienert

    Robert Bienert - 2003-09-12

    my sample program in a ZIP-file

     
  • Robert Bienert

    Robert Bienert - 2003-10-06

    Logged In: YES
    user_id=863586

    I think I found the problem: the declaration of Exit is not
    ANSI conform, but I compiled with -ansi. So in cstdlib there
    has to be something that "permits" using Exit when compiling
    with -ansi.

     
  • Earnie Boyd

    Earnie Boyd - 2013-01-31
    • labels: MinGW --> gcc, g++
    • status: closed-duplicate --> closed
    • resolution: --> duplicate
    • category: --> Duplicate
    • milestone: Known_bugs --> OTHER
     

Log in to post a comment.