#2129 Errors -- upgrade: mingw-get-0.6.2-mingw32-beta-20131004-1-bin.tar.xz

INSTALLER
pending
None
Bug
none
Unknown
False
2015-02-23
2013-11-04
Melchior
No

error report from MinGw-Get GUI:


upgrade: mingw-get-0.6.2-mingw32-beta-20131004-1-bin.tar.xz
lua error in pre-remove script:
[string "setup = require "setup" print( " running pre-..."]:1: module 'setup' not found:
    no field package.preload['setup']
    no file 'F:\Dev-MinGW\libexec\mingw-get\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\..\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\setup.dll'
    no file 'F:\Dev-MinGW\libexec\mingw-get\loadall.dll'
    no file '.\setup.dll'
 removing release mingw-get-0.6.1-mingw32-beta-20130910-1-bin.tar.xz
mingw-get-gui: *** ERROR *** mingw-get-0.6.1-mingw32-beta-20130910-1-bin.tar.xz: invalid manifest; no references
 installing mingw-get-0.6.2-mingw32-beta-20131004-1-bin.tar.xz
mingw-get-gui: *** ERROR *** F:\Dev-MinGW\/libexec/mingw-get/setup.lua: extraction failed
mingw-get-gui: *** ERROR *** cannot replace existing file
mingw-get-gui: *** ERROR *** F:\Dev-MinGW\/libexec/mingw-get/guistub.exe: extraction failed
mingw-get-gui: *** ERROR *** cannot replace existing file
mingw-get-gui: *** ERROR *** F:\Dev-MinGW\/libexec/mingw-get/lastrites.exe: extraction failed
mingw-get-gui: *** ERROR *** cannot replace existing file
mingw-get-gui: *** ERROR *** F:\Dev-MinGW\/libexec/mingw-get/unlink.js: extraction failed
mingw-get-gui: *** ERROR *** cannot replace existing file
mingw-get-gui: *** ERROR *** F:\Dev-MinGW\/libexec/mingw-get/shlink.js: extraction failed
mingw-get-gui: *** ERROR *** cannot replace existing file
mingw-get-gui: *** ERROR *** F:\Dev-MinGW\/var/lib/mingw-get/data/defaults.xml: extraction failed
mingw-get-gui: *** ERROR *** cannot replace existing file
lua error in post-install script:
[string "setup = require "setup" print( " running post..."]:1: module 'setup' not found:
    no field package.preload['setup']
    no file 'F:\Dev-MinGW\libexec\mingw-get\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\..\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\setup.dll'
    no file 'F:\Dev-MinGW\libexec\mingw-get\loadall.dll'
    no file '.\setup.dll'
upgrade: mingw-get-0.6.2-mingw32-beta-20131004-1-gui.tar.xz
lua error in pre-remove script:
[string "setup = require "setup" print( " running pre-..."]:1: module 'setup' not found:
    no field package.preload['setup']
    no file 'F:\Dev-MinGW\libexec\mingw-get\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\..\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\setup.dll'
    no file 'F:\Dev-MinGW\libexec\mingw-get\loadall.dll'
    no file '.\setup.dll'
 removing release mingw-get-0.6.1-mingw32-beta-20130910-1-gui.tar.xz
mingw-get-gui: *** ERROR *** mingw-get-0.6.1-mingw32-beta-20130910-1-gui.tar.xz: invalid manifest; no references
 installing mingw-get-0.6.2-mingw32-beta-20131004-1-gui.tar.xz
lua error in post-install script:
[string "setup = require "setup" print( " running post..."]:1: module 'setup' not found:
    no field package.preload['setup']
    no file 'F:\Dev-MinGW\libexec\mingw-get\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\..\libexec\mingw-get\setup.lua'
    no file 'F:\Dev-MinGW\libexec\mingw-get\setup.dll'
    no file 'F:\Dev-MinGW\libexec\mingw-get\loadall.dll'
    no file '.\setup.dll'
upgrade: libquadmath-4.8.1-4-mingw32-dll-0.tar
 removing release libquadmath-4.8.1-3-mingw32-dll-0.tar
 installing libquadmath-4.8.1-4-mingw32-dll-0.tar
upgrade: libgomp-4.8.1-4-mingw32-dll-1.tar
 removing release libgomp-4.8.1-3-mingw32-dll-1.tar
 installing libgomp-4.8.1-4-mingw32-dll-1.tar
upgrade: libssp-4.8.1-4-mingw32-dll-0.tar
 removing release libssp-4.8.1-3-mingw32-dll-0.tar
 installing libssp-4.8.1-4-mingw32-dll-0.tar
upgrade: libgcc-4.8.1-4-mingw32-dll-1.tar
 removing release libgcc-4.8.1-3-mingw32-dll-1.tar
 installing libgcc-4.8.1-4-mingw32-dll-1.tar
upgrade: gcc-core-4.8.1-4-mingw32-dev.tar.lzma
 removing release gcc-core-4.8.1-3-mingw32-dev.tar.lzma
 installing gcc-core-4.8.1-4-mingw32-dev.tar.lzma
upgrade: gcc-core-4.8.1-4-mingw32-lic.tar.lzma
 removing release gcc-core-4.8.1-3-mingw32-lic.tar.lzma
 installing gcc-core-4.8.1-4-mingw32-lic.tar.lzma
upgrade: gcc-core-4.8.1-4-mingw32-bin.tar.lzma
 removing release gcc-core-4.8.1-3-mingw32-bin.tar.lzma
 installing gcc-core-4.8.1-4-mingw32-bin.tar.lzma
upgrade: libstdc++-4.8.1-4-mingw32-dll-6.tar
 removing release libstdc++-4.8.1-3-mingw32-dll-6.tar
 installing libstdc++-4.8.1-4-mingw32-dll-6.tar
upgrade: gcc-c++-4.8.1-4-mingw32-dev.tar.lzma
 removing release gcc-c++-4.8.1-3-mingw32-dev.tar.lzma
 installing gcc-c++-4.8.1-4-mingw32-dev.tar.lzma
upgrade: gcc-c++-4.8.1-4-mingw32-bin.tar.lzma
 removing release gcc-c++-4.8.1-3-mingw32-bin.tar.lzma
 installing gcc-c++-4.8.1-4-mingw32-bin.tar.lzma
upgrade: gcc-core-4.8.1-4-mingw32-doc.tar.lzma
 removing release gcc-core-4.8.1-3-mingw32-doc.tar.lzma
 installing gcc-core-4.8.1-4-mingw32-doc.tar.lzma

ps:
sorry for not checking to see if there is another ticket open already I have limited time at the library here, out of time now so I will leave as is. for now

Discussion

  • Keith Marshall

    Keith Marshall - 2013-11-04
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,5 +1,7 @@
     error report  from MinGw-Get GUI:
     ______________________________________________________________________________________
    +
    +~~~~
     upgrade: mingw-get-0.6.2-mingw32-beta-20131004-1-bin.tar.xz
     lua error in pre-remove script:
     [string "setup = require "setup" print( " running pre-..."]:1: module 'setup' not found:
    @@ -85,6 +87,8 @@
     upgrade: gcc-core-4.8.1-4-mingw32-doc.tar.lzma
      removing release gcc-core-4.8.1-3-mingw32-doc.tar.lzma
      installing gcc-core-4.8.1-4-mingw32-doc.tar.lzma
    +~~~~
    +
     ______________________________________________________________________________
     ps:
     sorry for not checking to see if there is another ticket open already I have limited time at the library here, out of time now so I will leave as is. for now
    
    • status: unread --> pending
    • assigned_to: Keith Marshall
    • Group: OTHER --> INSTALLER
    • Type: Support --> Bug
     
  • Keith Marshall

    Keith Marshall - 2013-11-04

    The Lua issue is [#2052]; a consequence of this is that self-upgrade was broken in 0.6.0 and 0.6.1, for the GUI client; (it should still have worked from the command line). This is fixed in 0.6.2; the recommended way to get that is either to perform the upgrade of mingw-get itself, from the CLI, or to download the latest mingw-get-setup.exe, and run it to perform a reinstall.

    Somewhat more disturbing is the "invalid manifest: no references" error; I've never seen that, when performing a self-upgrade. As a consequence of that, the removal of 0.6.1 failed, leaving its installed files in place, and hence the conflicts, and refusal to replace them during the 0.6.2 install phase. This may require further follow up, if it remains an issue after a successful upgrade to 0.6.2, when subsequently moving forward to 0.6.3 (or later).

     

    Related

    Issues: #2052

  • Melchior

    Melchior - 2013-11-05

    thx for the update ^_^
    I'll try updating using the windows cmd batch files I have...
    I have a copy of my MinGW folder on my external HDD so I can update at the library, copy the new packages and their update xml files to my home PC...
    no new updates detected..

    According to FILE-Version info
    - GUIMAIN.exe (v0.602.22340.1)

    • mingw-get.exe -V
      -- reponse {mingw-get version 0.6.2-beta-20131004-1}

    so despite complaining about the upgrade it appears as though it did it anyway...?_?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks