#2019 pthreads-w32 version in mingw32-pthreads-w32.xml

INSTALLER
closed
None
Bug
fixed
Known_bugs
False
2014-11-24
2013-08-28
guardus
No

When I try to install mingw32-pthreads-w32-dev, it looks like it is grabbing 2.9.0.

$ mingw-get install mingw32-pthreads-w32-dev
install: pthreads-w32-2.9.0-mingw32-pre-20110507-2-dev.tar.lzma
...

When I try to install mingw32-pthreads-w32-dll, it looks like it is grabbing 2.9.1.

$ mingw-get install mingw32-pthreads-w32-dll
install: pthreads-w32-2.9.1-1-mingw32-dll.tar.lzma
...

In mingw32-pthreads-w32.xml, I see 2.9.1 for dll, but for dev, doc, and lic, I see 2.9.0. Should these also refer to 2.9.1?

I do see 2.9.1 files for dev, doc, and lic at https://sourceforge.net/projects/mingw/files/MinGW/Base/pthreads-w32/pthreads-w32-2.9.1/

Discussion

  • Earnie Boyd

    Earnie Boyd - 2013-08-28
    • status: unread --> open
    • assigned_to: Earnie Boyd
    • Type: Support --> Bug
     
  • Earnie Boyd

    Earnie Boyd - 2013-08-28

    Looks like I fat fingered the 9 for an 8 for -dev and completely forgot -lic an -doc. I'm building the distribution now for a new publication.

     
  • Earnie Boyd

    Earnie Boyd - 2013-08-28
    • Resolution: none --> fixed
    • Category: Unknown --> Known_bugs
     
  • Earnie Boyd

    Earnie Boyd - 2013-08-28
    • status: open --> closed