I did notice one minor detail. In /mingw/include/_mingw.h it says
#if (__GNUC__ < 3 || !defined(__GNUC_MINOR__) || (__GNUC__ == 3 && __GNUC_MINOR__ < 4) || (__GNUC__ == 3 && __GNUC_MINOR__ >= 4 && __GNUC_PATCHLEVEL__ < 5)) #error ERROR: You must use a GNU Compiler version >= 3.4.5. #endif
That __GNUC_MINOR__ >= 4 should perhaps be __GNUC_MINOR__ == 4. Right
now a hypothetical gcc 3.5.0 would give the error message. Of course,
there is no gcc 3.5.x (as 4.0.x came after 3.4.x), so there is not
really any problem.
Log in to post a comment.