#1630 minimum version mismatch in winbase.h

closed-fixed
2012-08-04
2012-04-13
Anonymous
No

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-04-13

    proposed fix

     
  • Chris Sutcliffe

    Chris Sutcliffe - 2012-04-28

    Do we know for certain these functions are not available in Win2k? Microsoft no longer supports Win2k and went through a process of updating MSDN to make all 'minimum support versions' to be XP (where it was Win2k previously).

     
  • Jan Ringoš

    Jan Ringoš - 2012-04-29

    Platform SDK v7.0 (roughly from late 2008) also states Windows XP as minimum supported version for GetModuleHandleEx[A/W] functions.

     
  • Chris Sutcliffe

    Chris Sutcliffe - 2012-04-29

    Thank you for confirming tringi. Are you the original author of the patch? I'd like to attibute this change to the appropriate author, but it currently lists the author as https://www.google.com/accounts.

     
  • Chris Sutcliffe

    Chris Sutcliffe - 2012-04-29
    • assigned_to: nobody --> ir0nh34d
     
  • Earnie Boyd

    Earnie Boyd - 2012-08-04

    The problem you report has caused modification in some fashion in
    the official CVS for the given package. The w32api and
    mingw-runtime official CVS reside in the winsup CVS directory tree for Cygwin. If you still find problems then please open a
    new report.

     
  • Earnie Boyd

    Earnie Boyd - 2012-08-04
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks