#155 Improper unwind-sjlj.o (libgcc.a)

OTHER
closed
gcc (462)
rejected
Known_bugs
2013-01-24
2002-06-17
No

This error pertains the new mingw build of gcc 3.1.

I got tons of
link error when building a C++ program, and I pinpointed the source of
error from incorrectly compiled unwind-sjlj.o, as shown
below:

$ ar x libgcc.a unwind-sjlj.o

$ objdump -ad unwind-
sjlj.o

unwind-sjlj.o: file format pe-i386
unwind-
sjlj.o

Disassembly of section .text:
(blank---no code
generated at all)

$ ls -al unwind-sjlj.o

-rw-r--r-- 1 Administ
None 252 Jun 13 14:41 unwind-sjlj.o

(Note the unusually small
object file size.) A sample error message is given
below:

x:/usr/local/lib/libstdc++.a(new_opv.o): In function
`Znaj':
/home/projects/cygwin.gcc3/i686-pc-cygwin/libstdc++-
v3/libsupc++/../../../../gcc-3.0.3/libstdc++-
v3/libsupc++/new_opv.cc:35: undefined reference to
`_Unwind_SjLj_Register'
/home/projects/cygwin.gcc3/i686-pc-
cygwin/libstdc++-v3/libsupc++/../../../../gcc-3.0.3/libstdc++-
v3/libsupc++/new_opv.cc:36: undefined reference to
`_Unwind_SjLj_Unregister'
/home/projects/cygwin.gcc3/i686-
pc-cygwin/libstdc++-v3/libsupc++/../../../../gcc-3.0.3/libstdc++-
v3/libsupc++/new_opv.cc:36: undefined reference to
`_Unwind_SjLj_Resume'

Could you have this fixed in later
builds?

Wirawan

Discussion

  • Luke Dunstan

    Luke Dunstan - 2002-06-18

    Logged In: YES
    user_id=30442

    If you look carefully at your error messages you will notice
    that you are trying to link with an incorrect libstdc++ library
    from a Cygwin gcc 3.0.3 compiler. If you don't know why, you
    could post the output of compiling and linking with gcc "-v"
    option, but I think the mailing list would be a better place
    because this is not a bug.

     
  • Danny Smith

    Danny Smith - 2002-06-22
    • status: open --> closed-rejected
     
  • Earnie Boyd

    Earnie Boyd - 2013-01-24
    • Description has changed:

    Diff:

    
    
    • status: closed-rejected --> closed
    • resolution: --> rejected
    • category: --> Known_bugs
    • milestone: Known_bugs --> OTHER
     

Log in to post a comment.