#1239 MinGW-5.1.4: installs binutils 2.17.50; should be 2.19

INSTALLER
closed
None
out-of-date
Known_bugs
2013-01-29
2009-01-18
time
No

I downloaded the installer, ran it and got an error. I tried again and still got the error:
File already exists - skipping mingwrt-3.15.1-mingw32.tar.gz
File already exists - skipping w32api-3.12-mingw32-dev.tar.gz
Downloading binutils-2.17.50-20060824-1.tar.gz
File Not Found (404)
Could not download binutils-2.17.50-20060824-1.tar.gz!

Discussion

  • Keith Marshall

    Keith Marshall - 2009-01-19

    Well, file binutils-2.17.50-20060824-1.tar.gz is definitely available for download; I just downloaded it successfully, from SF's heanet mirror, in Dublin, Ireland. This is not a bug, as you report it, but there may be a problem with the mirror you are using, in which case, you need to report it to the hosting service; there is nothing we can do about it.

    Normally, I would just close this as an invalid bug report. However, on this occasion, I am keeping it open with a modified title, to reflect the real bug; a `current' install should now use binutils-2.19, not binutils-2.17.50. (It should also use mingwrt-3.15.2, not mingwrt-3.15.1, and w32api-3.13, not w32api-3.12).

     
  • Keith Marshall

    Keith Marshall - 2009-01-19
    • assigned_to: nobody --> ir0nh34d
    • summary: binutils not found --> MinGW-5.1.4: installs binutils 2.17.50; should be 2.19
     
  • time

    time - 2009-01-19

    IIRC, I was not offered the choice of the mirror. Maybe some mirrors don't keep old versions ?

    When I tried to download it myself, this specific version was not available in the download page of Binutils (the page you get when you click "Download" in the project page, and "Download" on the Binutils line).

    I've just discovered that I must click on "GNU Binutils" instead of "Download" to get the required file. That's too bad the path is so hard for an automated install.

     
  • Earnie Boyd

    Earnie Boyd - 2009-01-19

    @time-world: All uploaded files to SF are kept forever and if the mirrors do not keep it then they are breaking their agreement with SF. The installer does not pick the mirror to use, that is the function of the SF service. You can set a default mirror for your SF account which may help.

    @keithmarshall: We have a problem of automation for the mingw.ini file since the last round of SF changes to the web service. We may need to change the installer to look at the current CVS version for it.

     
  • Keith Marshall

    Keith Marshall - 2009-01-21

    Time-World,
    > When I tried to download it myself, this specific version was not
    > available in the download page of Binutils (the page you get when
    > you click "Download" in the project page, and "Download" on the
    > Binutils line).

    That's correct; the download link on the project's main page takes you to a page which offers only the most recent version. That behaviour is specified by SF, and is beyond our control.

    > I've just discovered that I must click on "GNU Binutils" instead
    > of "Download" to get the required file.

    Yes, you have to do that, to see historical versions. Again, that is the way SF make it work, for *all* projects, and we can't change it.

    > That's too bad the path is so hard for an automated install.

    The automated installer doesn't use the links on the project page; it has a specific file reference hard coded into a bundled .ini file, and *every* SF mirror is *required* to have that file available for download, else, as Earnie says, the mirror provider is in breach of his hosting agreement with SF.

    When you run the installer, its first action is to search for an updated .ini file, hosted at a designated public URL. The issue is that no update for that .ini file has been published, to reflect the current release state of project packages.

    Earnie,
    > We have a problem of automation for the mingw.ini file
    > since the last round of SF changes to the web service.

    I know; the subject was discussed on the ML, two or three months ago.

    > We may need to change the installer to look at the
    > current CVS version for it.

    I thought we'd already agreed that would be done; if it hasn't happened yet, then *someone* needs to address it. However, the mingw.ini file is now marked as "dead" on CVS trunk. It is still "alive" on branch MinGW-5_1, but that branch tag itself refers to revision 1.12.2.1, forked off version 1.12, which Chris committed in Jan-2007; it also serves as a common branch point for the non-existent, and never likely to be, MinGW-6_0.

    The most recent commit on trunk, predating "death" at revision 1.20, in Aug-2008, is Chris's version 1.19, in May-2008; this bears the tag MinGW-5_1_4. ViewCVS reveals no evidence of further update activity on the MinGW-5_1 branch, after this date.

     
  • Earnie Boyd

    Earnie Boyd - 2009-01-21

    I will take a look at the CVS and add it back to HEAD for the MinGW package.

     
  • Earnie Boyd

    Earnie Boyd - 2012-08-03

    Thank you for your interest in the MinGW project. This post is old and I am therefore closing it, if problems still exist
    please resubmit.

    The MinGW Project Administrators.

     
  • Earnie Boyd

    Earnie Boyd - 2012-08-03
    • status: open --> closed-out-of-date
     
  • Earnie Boyd

    Earnie Boyd - 2013-01-29
    • labels: MinGW Installer -->
    • status: closed-out-of-date --> closed
    • resolution: --> out-of-date
    • category: --> Known_bugs
    • milestone: --> INSTALLER
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks