#100 CC1 has started crashing

OTHER
closed
gcc (462)
rejected
Known_bugs
2013-01-24
2001-12-28
Matt Smith
No

I was compiling a C program with Dev-CPP 4.0.
Everything was going fine but now I get this.
Rebooting didn't help. I have Cel500, 128Meg ram,
Win98SE. I was using the latest MinGW snapshot

CC1 caused an invalid page fault in
module CC1.EXE at 016f:0054a422.
Registers:
EAX=026d6f10 CS=016f EIP=0054a422 EFLGS=00010246
EBX=00000015 SS=0177 ESP=026bf800 EBP=026bfd28
ECX=026bff68 DS=0177 ESI=026bf89c FS=3f97
EDX=02d0a778 ES=0177 EDI=02d086f8 GS=0000
Bytes at CS:EIP:
8b 42 10 a3 48 39 57 00 8b 42 0c a3 4c 39 57 00
Stack dump:
00000000 00000001 026bfd28 0054b3b2 00000000 027e056a
0040879f 0046bbf8 026dc100 27262524 00000190 0000002a
0000035c 00000014 3b3a3938 3f3e3d3c

Discussion

  • Matt Smith

    Matt Smith - 2001-12-28

    Logged In: YES
    user_id=229297

    This is the source line which triggered it (missing
    semicolon)

    long w,h; int mode //used in resize input

     
  • Luke Dunstan

    Luke Dunstan - 2002-05-22

    Logged In: YES
    user_id=30442

    GCC 2.95.3-7 and 3.1 do not crash with the single line of input
    given here. A test case that reproduces the problem is
    required, or this bug will have to be closed.

     
  • Danny Smith

    Danny Smith - 2002-05-26
    • status: open --> closed-rejected
     
  • Earnie Boyd

    Earnie Boyd - 2013-01-24
    • status: closed-rejected --> closed
    • resolution: --> rejected
    • category: --> Known_bugs
    • milestone: --> OTHER
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks