#232 libstdc++ dependency on msvcrt.dll

closed-invalid
nobody
5
2011-12-16
2011-07-30
No

Why this dialog?
-----------------------
Error starting program
The LIBSTD++-6.DLL is linked to missing export MSVCRT.DLL:____lc_codepage_func.
-----------------------
I see no reason why MingW-w64 should be depending upon MSVCRT.DLL.
and by the way, this DLL is not on Windows 98SE, which happens to be my target machine.

This didn't used to be a problem.
I am using the auto build.
c:\mingw-w32-bin_i686-mingw_20110516\bin\i686-w64-mingw32-g++.exe
c:\mingw-w64-bin_i686-mingw_20110516\bin\x86_64-w64-mingw32-g++.exe

If you still need source to reproduce, I will try to come up with something.

Discussion

  • Jim Michaels

    Jim Michaels - 2011-07-31

    source file, only pay attention to the win32 functions

     
  • Jim Michaels

    Jim Michaels - 2011-07-31

    compiler output with switches

     
  • Jim Michaels

    Jim Michaels - 2011-07-31

    source file and compiler output w/gcc compile switches attached.

    again, this must be executed on windows 9x to get this error (maybe ME too since it's basically the same architecture).

     
  • Jim Michaels

    Jim Michaels - 2011-07-31

    well, maybe the function listed had only 3 _'s, that looks a little long.

     
  • Jim Michaels

    Jim Michaels - 2011-07-31

    oops, that should be LIBSTDC++-6.DLL, typo, too bad I can't go back and fix it.

     
  • Ozkan Sezer

    Ozkan Sezer - 2011-07-31

    This artifact has been marked as a duplicate of artifact 3300841 with reason:
    duplicate

     
  • Ozkan Sezer

    Ozkan Sezer - 2011-07-31
    • status: open --> closed
     
  • Ozkan Sezer

    Ozkan Sezer - 2011-07-31
    • status: closed --> closed-duplicate
     
  • Jim Michaels

    Jim Michaels - 2011-11-20

    there is another dependency. I don't know if it's still there, but I just ran my df program on windows 98 compiled with auto 32 20110812, and I got this:

    Error Starting Program
    The LIBSTDC++-6.DLL is linked to missing export MSVCRT.DLL:_fstat64

     
  • Jim Michaels

    Jim Michaels - 2011-11-20
    • status: closed-duplicate --> open-duplicate
     
  • Kai Tietz

    Kai Tietz - 2011-12-16

    We support Windows native system based on MS runtime. Therefore C runtime is always that one in msvcrt by default, and we can't change that. If you prefer a different runtime-version from MS (like mvcr80.dll or different), then feel free to build your modified toolchain for that.
    The other point is that mingw-w64 does not support Windows OSes below XP officially. The mingw-w64 stuff might work well for Windows 2000, but this isn't guaranteed by us.

     
  • Kai Tietz

    Kai Tietz - 2011-12-16
    • status: open-duplicate --> closed-invalid
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks