#1 .NET FW 2.0

closed
nobody
None
5
2006-06-22
2005-05-19
Anonymous
No

We are doing some tests with DOTNET Framework
V2.0 (Beta2).

We are encountering a problem with MPM Ver 1.2.3.
We get an excpetion error when assigning the
Datasource value.

We download loaded the source cod efor V1.2.4 and
compliled under FW 2.0 and get the same problem

We could trace the problem to the Constructor :
MpmConnectionStringObject in
MpmConnectionObject.cs

The exception occur at line :
//
// Check that it is a
valid data source name
//
_dataSourceDescriptor
= (MpmDataSourceDescriptor) MpmInfo.DataSources
[_dataSourceName];

Any ideas ?

Discussion

  • Bengt Gunne

    Bengt Gunne - 2005-05-19

    Logged In: YES
    user_id=895705

    Yes, I have been porting to ver 2.0 the last few weeks. The
    problem is due to a change in the Type.GetType method. It
    does not accept the startupClass (see MpmInfo.cs) as
    specified earlier.

    If you remove the last reference to Mimer.Mpm.Data-
    ConfigReg after the Culture=Neutral you should get it to work.

    Hopefully I can provide you with an Mpm for FW 2.0 in the
    next few weeks.

     
  • Fredrik Ĺlund

    Fredrik Ĺlund - 2006-06-22

    Logged In: YES
    user_id=897766

    Since Mimer Provider Manager v 2.0.1 that is target for .NET
    Framework 2.0 is released I'm closing this issue.

     
  • Fredrik Ĺlund

    Fredrik Ĺlund - 2006-06-22
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks