Installing MinionPro in MiKTeX 2.9 and Seven

  • Xavier Brusset

    Xavier Brusset - 2011-06-20


    I recently installed Windows Seven 32 on my PC. Installed MiKTeX 2.9 from
    scratch and then copied all the files I thought were needed for MinionPro to
    run also as in my prior isntallation of Windows XP.

    I updated updmap.cfg in the folder indicated to me by kpsewhich
    I added in (same as indicated by kpsewhich)
    I added the pdb otf enc and afm files where they should be from my other XP

    Yet, when I run pdftexify on a file which includes
    and which used to work on my XP installation, I get the following error:

    ("C:\Program Files\MiKTeX 2.9\tex\latex\amsfonts\ueuf.fd"
    File: ueuf.fd 2009/06/22 v3.00 Euler Fraktur

    Here is how much of TeX's memory you used:
    3837 strings out of 494049
    61596 string characters out of 3148481
    73521 words of memory out of 3000000
    7101 multiletter control sequences out of 15000+200000
    151202 words of font info for 54 fonts, out of 3000000 for 9000
    715 hyphenation exceptions out of 8191
    40i,10n,58p,396b,437s stack positions out of 5000i,500n,10000p,200000b,50000s

    !pdfTeX error: C:\Program Files\MiKTeX 2.9\miktex\bin\pdflatex.exe (file
    Pro-Regular-lf-l1-t1): Font MinionPro-Regular-lf-l1-t1 at 382 not found
    ==> Fatal error occurred, no output PDF file produced!

    What have I forgotten?
    What did I do wrong?

  • Xavier Brusset

    Xavier Brusset - 2011-06-20

    It seems that I have found my mistake. I had forgotten to copy the MinionPro
    otf files from the Windows/fonts directory known to MiKTeX. I also had
    forgotten to copy the .enc files from the previous installation of MiKTeX 2.9
    under windows XP.

  • Xavier Brusset

    Xavier Brusset - 2011-06-21

    Hi a third time,
    I have now tried using the MinionPro-RRegular font with LuaLaTeX. For some
    reason, it doesn't work. LuaLaTeX does work with Times New Roman and Tex-Gyre

    this is the error that appears in the log:

    ("C:/Program Files/MiKTeX 2.9/tex/latex/fontspec/fontspec.cfg"))
    ! LuaTeX error ...ram Files/MiKTeX 2.9/tex/latex/fontspec/fontspec.lua:39:
    mpt to index field 'shared' (a nil value)
    stack traceback:
    ...ram Files/MiKTeX 2.9/tex/latex/fontspec/fontspec.lua:39: in function 'check
    ...ram Files/MiKTeX 2.9/tex/latex/fontspec/fontspec.lua:96: in function 'check
    <\directlua >:1: in main chunk.
    \fontspec_check_script:nTF ..."zf@basefont","#1")}
    \if@tempswa \prg_return_tr...
    l.8 \setmainfont{MinionPro-Regular}

    ? x
    The lines of code come from LuaTex.cfg

    Any clue?


  • U_Fischer

    U_Fischer - 2011-06-22

    That's the wrong place to ask questions about fontspec/luaotfload.
    comp.text.tex, the lualatex mailing list, tex.stackexchange and others are

    Also your question is missing important informations: A complete minimal
    example (with \listfiles) and the log-file.

    Did you run an update after the installation?

    Ulrike Fischer


Log in to post a comment.