Cannot open Dvi files directly

federico
2010-06-22
2012-10-17
  • federico

    federico - 2010-06-22

    Hello!
    I had Miktex 2.6 on my laptop (the OS is Windows Vista).
    However, when tring to open a Dvi file directly, I used to get the following
    error message:
    "Yet another viewer has stopped working", and below, first: "Windows is
    checking for a solution to the problem", then:"A problem caused the program to
    stop working correctly. Windows will close the program and notify you if a
    solution is available".
    Then there was a window popping up:"Windows cannot find" followed by the path
    to the file and "Make sure you typed the name
    correctly, and then try again."
    Also, a "Miktex problem Report" windows used to open, where I read "cannot
    find modes.mf" (see below).

    MiKTeX Problem Report
    Message: cannot find modes.mf
    Data:
    Source: C:\work3\miktex-2.6\Libraries\MiKTeX\Core\mfmodes.cpp
    Line: 56
    MiKTeX: 2.6
    OS: Microsoft Windows Vista Business Edition Service Pack 2 (Build 6002)
    SystemAdmin: yes
    PowerUser: no
    SharedSetup: yes
    BinDir: C:\Program Files\MiKTeX 2.6\miktex\bin
    Root0: C:\Users\Federico\AppData\Roaming\MiKTeX\2.6
    Root1: C:\Users\Federico\AppData\Local\MiKTeX\2.6
    Root2: C:\ProgramData\MiKTeX\2.6
    Root3: C:\Program Files\MiKTeX 2.6
    Install: C:\Program Files\MiKTeX 2.6
    UserConfig: C:\Users\Federico\AppData\Roaming\MiKTeX\2.6
    UserData: C:\Users\Federico\AppData\Local\MiKTeX\2.6
    CommonConfig: C:\ProgramData\MiKTeX\2.6
    CommonData: C:\ProgramData\MiKTeX\2.6

    The same used to occur while opening the file using the "Open with" options
    (by the way, "dvi" is correctly associated with Yap).
    Also, if I used the file "yap.exe", I couldn't open any ".dvi" file then.
    On the contrary, if I chosed to view the output immediately after running the
    tex file, it worked.
    I then uninstalled Miktex and Texnik Center, and installed Miktex 2.8, updated
    all packages, and then re-installed Texnik Center. Now I don't get any error
    message from Miktex and I can open dvi files via Yap.exe.
    However, I still can't open Dvi files neither directly, or via "open with",
    and receive the same error messages as before from Windows.
    Do you have an idea of why it occurs?
    TIA,
    Federico

     
  • federico

    federico - 2010-06-28

    I found a solution by changing the registry entry in
    HKLM\Software\Classes\MiKTex.dvi.2.8\shell\open\command: from the actual
    Yap.exe address, to a fake one (pretending Yap.exe were located on the
    desktop). However, I have no idea why it has worked. Do you have any clue?
    Federico

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks