R related packages crash in 4.6.2 MacOSX

Help
Anonymous
2011-01-27
2013-05-20
  • Anonymous - 2011-01-27

    Hi,
    I downloaded MeV 4.6.2 and when using LIMMA or SAM with R the whole program crashes.

     
  • raktim

    raktim - 2011-01-27

    Hi,

    Sorry to hear that.
    What is the specification of your MAC and what version of R is installed on your system.
    Raktim

     
  • Anonymous - 2011-01-28

    I have a MacBook Pro running MacOSX 10.6.6. R version is 2.9.2. I tried with 2.12 but I got the same problem.
    Thanks
    Dimitrios

     
  • Anonymous - 2011-05-17

    Hi
    I downloaded 4.7 hoping it will remedy the problem but the problem persists. when i download the package the folder with the Rpackages is empty.

     
  • Sylvain Foisy

    Sylvain Foisy - 2011-05-20

    Hi,

    If I may add to this since I am affected with the exact same problem. I am running MeV 4.7 on a MAcBook Pro with R 2.13 installed and Limma is a no show. I get a very cryptic error message and this in the rhook.log file:

    # -----------------------------
    # RHook LOG FILE     : rhook.log
    # START TIME   : Fri May 20 14:37:24 EDT 2011
    # -----------------------------

    PORT :501 PORT not allowed after EPSV ALL

    sun.net.ftp.FtpProtocolException: PORT :501 PORT not allowed after EPSV ALL

    at sun.net.ftp.FtpClient.openDataConnection(FtpClient.java:435)
    at sun.net.ftp.FtpClient.get(FtpClient.java:550)
    at sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(FtpURLConnection.java:382)
    at org.tigr.rhook.RHook.getPropInfoRhook(RHook.java:1064)
    at org.tigr.rhook.RHook.loadRHookProperties(RHook.java:225)
    at org.tigr.rhook.RHook.startRSession(RHook.java:164)
    at org.tigr.microarray.mev.cluster.algorithm.impl.LIMMA.runRAlg(LIMMA.java:519)
    at org.tigr.microarray.mev.cluster.algorithm.impl.LIMMA.execute(LIMMA.java:134)
    at org.tigr.microarray.mev.cluster.gui.impl.limma.LIMMAGUI.execute(LIMMAGUI.java:244)
    at org.tigr.microarray.mev.MultipleArrayViewer$7.run(MultipleArrayViewer.java:2618)
    at java.lang.Thread.run(Thread.java:680)

    # -----------------------------
    #           << END OF SESSION >>             
    # -----------------------------
    # STOP TIME    : Fri May 20 14:38:49 EDT 2011
    # ELAPSED TIME : 85 seconds.
    # -----------------------------

    It this means anything to anyone… FYI, limma never worked either on 4.6.1 (the latest version that I work with before). This is quite important since ti seems that more and more of MeV's functions will get connected to R.

    Best regards

    Sylvain

     
  • Sylvain Foisy

    Sylvain Foisy - 2011-05-20

    Hi,

    Finally… I had to remove all traces of R 2.13 on my Mac and install R 2.11.1 instead. Everything seems to work. This will certainly impact some of my work, probably to be solve via VMs running 2.13…

    Sylvain

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks