Problem with GSEA and Java

Help
Marit
2010-03-02
2013-05-20
  • Marit

    Marit - 2010-03-02

    Hi,

    I recently started using MeV and I am especially interested in using your GSEA implementation. However, I am not successful in running this application with my own data. I get the following error message in a box called "Analysis Error":

    java.lang.NullPointerException
    at org.tigr.microarray.mev.cluster.algorithm.impl.gsea.GSEAUtils.populateTestStatistic(GSEAUtils.java:39)
    at org.tigr.microarray.mev.cluster.gui.impl.gsea.GSEAGUI.execute(Unknown Source)
    at org.tigr.microarray.mev.MultipleArrayViewer$7.run(MultipleArrayViewer.java:2609)
    at java.lang.Thread.run(Thread.java:619)

    This happens in the step of GSEA where the viewers are generated. Therefore I suspect that it is really a java problem and not an issue of GSEA.

    Can you help me to solve this problem? If not, do you have an example data set and analysis pipeline for GSEA to test whether it is a problem with MeV or with my data? In the short tutorial on the MeV homepage I cannot see which data you are using and access is denied to a detailed look at the screenshots.

    Thanks a lot in advance!
    Marit

     
  • Sarita Nair

    Sarita Nair - 2010-03-02

    Hi Marit,

    Thanks for using MeV.

    I just tested GSEA  (MeV v 4.5.1) using the data set  leukemia_ross_small_HG-U133A.txt   (data/Affymetrix Files/) and it worked just fine for me. This also happens to be the data set used in the short tutorial on our website. 

    If you can send us your data set, gene set  (mev@jimmy.harvard.edu) and information on the groups in your samples, I can take a look.

    Sorry for the inconvenience,
    Best,
    Sarita

     
  • Marit

    Marit - 2010-03-05

    Dear Sarita,

    I tried to send you the data but the mail returns since it is too large. The size of the archived file is 8 MB. Is there any possibility to send it to you?

    Thanks a lot,
    Marit

     

Log in to post a comment.