importing Affymetrix files in MeV

Guy Bottu
  • Guy Bottu

    Guy Bottu - 2010-08-24

    I have a file created using the Expresion Console of Affymetrix. The file contains lines :
    Probe Set ID GSM154768.ex2.mas5-Signal GSM154768.ex2.mas5-Detection GSM154768.ex2.mas5-Detection p-value GSM154769.ex2.mas5-Signal……..
    AFFX-BioB-5_at 298.9997 P 0.004017214 290.1384 P……..
    So, this corresponds quite well to the description in the MeV manual. I tried to load it using the  loader menu option  for "Affymetrix GCOS(using MAS5)Files", of course with  "Intensity  with Detetction and P-values" checked. But  in the pop-up box the top bar remains empty and the bottom bar goes to 99% and then it stalls.  I thought that the problem was maybe with the loading of the annotation file. I tried as well  to uncheck "load annotation" as downloading automatically as using a local file. When I use a local file a list of names appears in  the DOS box of Windows, so something is happening. However the loading still stalls the same way, so the problem might be with the Affymatrix expression data file although it looks good.

    Did someone already successfully transfer date from Expression Console to MeV ? Any clue about what I am missing ?

    Guy Bottu,
    University of Brussels

  • Guy Bottu

    Guy Bottu - 2010-08-24

    Well, in the mean time I discovered myself the solution : it turns out that the files created by the Affymetrix expression Console contain at the end a few extra end-of-line characters. These make MeV stall and the cure is to use an editor to remove them….

  • Eleanor Howe

    Eleanor Howe - 2010-08-24

    Hi there Guy,

    I'm glad to hear you've already figured out the problem with the Affy files. Would you mind doing me a favor and sending me an example of one of these files with the extra end-of-line characters? It doesn't need to be real data, but it would help us fix the file loader if we had a known problem-causing file to test with.


  • Guy Bottu

    Guy Bottu - 2010-08-31

    Dear Eleanor,  I just looked back at the forum and saw your question. But I have a (silly) problem : I have not yet figured out how I can send a file as attachment in the forum mail system…


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks