Windows 7-64 bit - Java 3D PCA analysis Error

  • Susan Koziel

    Susan Koziel - 2011-04-08

    I'm running MeV4_6_2 on a 64 bit system running Windows 7 Professional

    In the inital start up  MeV lists that it can find:
    Java Runtime Environment ver 1.6.0_24
    Java Virtual machine ver 19.1-b02
    Java 3D Runtime Environement ver 1.2

    But when I run The PCA analysis I get this error:

    java.lang.Exception: Java3D is not installed. The 3D viewer cannot be created.
    at org.tigr.microarray.mev.cluster.gui.impl.pca.PCA3DViewer.<init>(
    at org.tigr.microarray.mev.cluster.gui.impl.pca.PCAGUI.add3DViewNode(
    at org.tigr.microarray.mev.cluster.gui.impl.pca.PCAGUI.addResultNodes(
    at org.tigr.microarray.mev.cluster.gui.impl.pca.PCAGUI.execute(
    at org.tigr.microarray.mev.MultipleArrayViewer$
    at Source)

    I have tried reinstalling Java 3D as well as MeV. Neither seems to help.
    I am not a programer, so if it requires me to alter something in the program somewhere if you could make your description of what I need to do to which file detailed and somewhat idiot proof, it would be appreciated.

    Thanks for any help you can give

  • Maria Klapa

    Maria Klapa - 2012-07-19


    I have the same problem and I cannot find a plausible solution on the site. Could you please help? I have tried installing Java 3D for Win32, I changed the path and classpath and still nothing has worked. I would greatly appreciate a reply

  • YiHong Li

    YiHong Li - 2013-01-15

    Dear Susan,

    This is Yihong.  Could you please let me know if you ever solved the Windows 7 issue?  I am running the same problem and hope you could share your experience with me.  Appreciated very much in advance. 



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks