MeV error during startup since Jun 2013

Help
DNA@UBT
2013-06-17
2014-02-07
  • DNA@UBT

    DNA@UBT - 2013-06-17

    Hello

    I have realized last week, that MeV starts with an error message (see
    attached screenshot). MeV started without problems since I downloaded it
    about 1 year ago.

    Has anything changed at your servers?

    Best regards

    Alfons

    Dr. Alfons Weig

    DNA-Analytik & Ökoinformatik - Univ. Bayreuth

    Universitätsstrasse 30

    95447 Bayreuth - Germany

    Tel. +49 (0)921-552457

    www.daneco.uni-bayreuth.de

     
  • Omid Fotouhi

    Omid Fotouhi - 2013-07-10

    Hi
    I have the same problem. Although I downloaded my software last year (version MeV_4_8_1), it shows the error massage (an error was encountered during file download. null).
    I tried to install the new version; reinstall Java; try another computer: it doesn't work: doesn't show the heatmap or perform clustering analysis.

     
    • John Quackenbush

      Thanks. We'll look into the problem and may contact you for more
      information.

      On 7/10/2013 8:10 AM, Omid Fotouhi wrote:

      Hi
      I have the same problem. Although I downloaded my software last year
      (version MeV_4_8_1), it shows the error massage (an error was
      encountered during file download. null).
      I tried to install the new version; reinstall Java; try another
      computer: it doesn't work: doesn't show the heatmap or perform
      clustering analysis.


      MeV error during startup since Jun 2013
      https://sourceforge.net/p/mev-tm4/discussion/378852/thread/62807615/?limit=25#974e


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/mev-tm4/discussion/378852/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
    • mary

      mary - 2013-07-10

      Hi,

      It is absolutely wird, before it worked for me but now when I load my old
      data it shows heat map but with my new data (whic have exactly the same
      format) it does not work.

      On Wed, Jul 10, 2013 at 2:10 PM, Omid Fotouhi omidfotouhi@users.sf.netwrote:

      Hi
      I have the same problem. Although I downloaded my software last year
      (version MeV_4_8_1), it shows the error massage (an error was encountered
      during file download. null).
      I tried to install the new version; reinstall Java; try another computer:
      it doesn't work: doesn't show the heatmap or perform clustering analysis.


      MeV error during startup since Jun 2013https://sourceforge.net/p/mev-tm4/discussion/378852/thread/62807615/?limit=25#974e

      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/mev-tm4/discussion/378852/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
    • levk

      levk - 2013-07-25

      Could you try starting from the command line and paste or attach the output? Thanks.

       
      • ADDUOx

        ADDUOx - 2013-08-30

        I'm getting something similar on start-up. Initialisation and output below:

        MultiExperimentViewer - version 4.9.0 - Windows 7
        Java Runtime Environment version: 1.7.0_25
        Java Runtime Environment vendor: Oracle Corporation
        Java Virtual Machine name: Java HotSpot(TM) Client VM
        Java Virtual Machine version: 23.25-b01
        Java Virtual Machin vendor: Oracle Corporation
        Java 3D Runtime Environment: Java 3d Core Runtime Environment
        Java 3D Runtime Environment vendor: Sun Microsystems, Inc.
        Java 3D Runtime Environment version:1.5.1
        Operating System name: Windows 7
        Operating System version: 6.1
        Operating System architecture: x86
        MeV Build: 2731
        MeV Revision Date: 2013/04/03 11:29:16
        MeV Branch: http://mev-tm4.sourceforge.net/svnroot/mev-tm4/trunk
        Java.util.NoSuchElementException: There are no more tokens!
        at org.tigr.util.StringSplitter.nextToken(StringSplitter.java:87)
        at org.tigr.microarray.mev.annotation.PublicURL.loadURLs(PublicURL.java:414)
        at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:265)
        at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)
        org.tigr.microarray.mev.annotation.InvalidAnnMappingFileException
        at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:266)
        at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)

        Thanks in advance for any help you can offer.

         
  • Catriona Tate

    Catriona Tate - 2013-08-22

    I have the same error running MeV4.8.1 on Mac OSX 10.8.4. I also note that the RPackages directory is empty. Much of the application works anyway, but I can't use LIMMA.

     
  • Peter Hoyt

    Peter Hoyt - 2013-09-27

    Same error here using Windows 7 and MeV4.9 and it is worsened by trying to run the batch file if that helps. If you try to go to:
    http://mev-tm4.sourceforge.net/svnroot/mev-tm4/trunk
    you get (basically) a 404 error.

    Here is the error text:
    MultiExperimentViewer - version 4.9.0 - Windows 7
    Java Runtime Environment version: 1.7.0_40
    Java Runtime Environment vendor: Oracle Corporation
    Java Virtual Machine name: Java HotSpot(TM) 64-Bit Server VM
    Java Virtual Machine version: 24.0-b56
    Java Virtual Machine vendor: Oracle Corporation
    Java 3D Runtime Environment: Java 3D Core Runtime Environment
    Java 3D Runtime Environment vendor: Sun Microsystems, Inc.
    Java 3D Runtime Environment version:1.2 #I will check this
    Operating System name: Windows 7
    Operating System version: 6.1
    Operating System architecture: amd64
    MeV Build: 2731
    MeV Revision Date: 2013/04/03 11:29:16
    MeV Branch: http://mev-tm4.sourceforge.net/svnroot/mev-tm4/trunk
    java.util.NoSuchElementException: There are no more tokens!
    at org.tigr.util.StringSplitter.nextToken(StringSplitter.java:87)
    at org.tigr.microarray.mev.annotation.PublicURL.loadURLs(PublicURL.java:
    414)
    at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:265)
    at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)
    org.tigr.microarray.mev.annotation.InvalidAnnMappingFileException
    at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:266)
    at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)

     
    Last edit: Peter Hoyt 2013-09-27
  • levk

    levk - 2013-10-03

    Please try removing ".mev" folder in your home folder; I think you may have some corrupted content there.

     
  • Peter Hoyt

    Peter Hoyt - 2013-10-03

    Thanks for the reply. Please help as I'm trying to write a grant! Your suggestion changed the behavior slightly, but still the software gave similar errors:
    MultiExperimentViewer - version 4.9.0 - Windows 7
    Java Runtime Environment version: 1.7.0_40
    Java Runtime Environment vendor: Oracle Corporation
    Java Virtual Machine name: Java HotSpot(TM) 64-Bit Server VM
    Java Virtual Machine version: 24.0-b56
    Java Virtual Machine vendor: Oracle Corporation
    Java 3D Runtime Environment: 3D Graphics API for the Java Platform
    Java 3D Runtime Environment vendor:
    Java 3D Runtime Environment version:1.5.2
    Operating System name: Windows 7
    Operating System version: 6.1
    Operating System architecture: amd64
    MeV Build: 2731
    MeV Revision Date: 2013/04/03 11:29:16
    MeV Branch: http://mev-tm4.sourceforge.net/svnroot/mev-tm4/trunk
    java.util.NoSuchElementException: There are no more tokens!
    at org.tigr.util.StringSplitter.nextToken(StringSplitter.java:87)
    at org.tigr.microarray.mev.annotation.PublicURL.loadURLs(PublicURL.java:
    414)
    at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:265)
    at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)
    org.tigr.microarray.mev.annotation.InvalidAnnMappingFileException
    at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:266)
    at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)

    Prior to the error, two windows asked for permission to connect to the internet. I agreed, but then got a small window titled "Data Download Error" and inside an exclamation mark on a yellow triangle saying "An error was encountered during file download: null". After clicking "OK" on that window, there was a second small window behind it with a java icon top-left titled Error downloading file. Inside this window is just a red octagon with an "X" inside it. Before I could click on that second window's "OK" button, the MEV viewer window pops open. This is when the error above appears in the MEV command window. I have placed MEV on the exceptions list of windows firewall. If I forbid MEV from connecting to the internet using the second request window, there are NO ERRORS.

     
  • Peter Hoyt

    Peter Hoyt - 2013-10-09

    Sorry to bump this thread, but this problem is persisting and after many hours of effort, I can't seem to fix it.

    Is there a method for removing all traces of MEV and re-installing? Using Windows 7.

    Thanks,

    Peter Hoyt

     
  • levk

    levk - 2013-10-09

    Please remove .mev folder in your home folder usually located at C:\Users\<Username>\ and try again

     
    • Peter Hoyt

      Peter Hoyt - 2013-10-09

      Thanks, I tried this again, but there is no change. I have removed the .mev folder many times now. Is there a file in there I can check for errors?

       
      • mary

        mary - 2013-10-10

        Hi,

        You can first upgrade your java. Check if you need Java for 32 bite or 64
        bite.

        I hope it helps.

        On Thu, Oct 10, 2013 at 12:06 AM, Peter Hoyt hoytpr@users.sf.net wrote:

        Thanks, I tried this again, but there is no change. I have removed the
        .mev folder many times now. Is there a file in there I can check for errors?


        MeV error during startup since Jun 2013https://sourceforge.net/p/mev-tm4/discussion/378852/thread/62807615/?limit=25#8c91/7452

        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/mev-tm4/discussion/378852/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/

         
        • Peter Hoyt

          Peter Hoyt - 2013-10-10

          Hi Mary,
          Yes, that's a good thing to suggest. I updated Java and made sure that I had both 32-bit and 64-bit installed. The batch file looks for the 32-bit version for 3D-functions. I'm not sure if the entire software uses 32-bit or 64-bit. Either way I should be covered. My current theory is that it is a permission issue.

           
          • Peter Hoyt

            Peter Hoyt - 2013-10-10

            It's not permissions, and I opened the firewall as much as I dared. Can someone point me to place to trouble-shoot? I've run out of options and need MeV up and running ASAP. Thanks.

            The error in the console window, if I allow MEV to access the internet is:

            "64 bit Win"
            C:\Program Files (x86)\MEV\MeV_4_9_0_r2731_win\MeV_4_9_0
            MultiExperimentViewer - version 4.9.0 - Windows 7
            Java Runtime Environment version: 1.7.0_40
            Java Runtime Environment vendor: Oracle Corporation
            Java Virtual Machine name: Java HotSpot(TM) Client VM
            Java Virtual Machine version: 24.0-b56
            Java Virtual Machine vendor: Oracle Corporation
            Java 3D Runtime Environment: Java 3D Core Runtime Environment
            Java 3D Runtime Environment vendor: Sun Microsystems, Inc.
            Java 3D Runtime Environment version:1.2.1.04
            Operating System name: Windows 7
            Operating System version: 6.1
            Operating System architecture: x86
            MeV Build: 2731
            MeV Revision Date: 2013/04/03 11:29:16
            MeV Branch: http://mev-tm4.sourceforge.net/svnroot/mev-tm4/trunk
            java.util.NoSuchElementException: There are no more tokens!
            at org.tigr.util.StringSplitter.nextToken(StringSplitter.java:87)
            at org.tigr.microarray.mev.annotation.PublicURL.loadURLs(PublicURL.java:414)
            at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:265)
            at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)
            org.tigr.microarray.mev.annotation.InvalidAnnMappingFileException
            at org.tigr.microarray.mev.TMEV.loadAnnotationsURLs(TMEV.java:266)
            at org.tigr.microarray.mev.TMEV.main(TMEV.java:216)

             
  • levk

    levk - 2013-10-10

    We can reproduce the error now; a fix is coming, but in the meantime you can safely ignore the error as it is inconsequential to MeV operation.

     
    Last edit: levk 2013-10-10
  • Peter Hoyt

    Peter Hoyt - 2013-10-11

    I appreciate your help. I downloaded the annotations_URLs.txt file and placed it into my .mev directory renaming the old file. Just FYI, I got the same error. I'll be looking for a patch and hope all goes well.

    -p

     
  • Peter Hoyt

    Peter Hoyt - 2014-02-06

    Still getting this error almost five months later.
    Have a workshop coming up and even if this doesn't affect the functionality, it makes my participants uneasy.

    Thanks.
    Peter

     
  • levk

    levk - 2014-02-07

    Should be fixed now, sorry for the delay.

     
    • Valery

      Valery - 2014-02-07

      Hi
      Please any idea/suggestions about this problem:

      java.lang.ClassCastException: org.tigr.microarray.mev.SlideDataElement cannot be cast to org.tigr.microarray.mev.RNASeqElement
      at org.tigr.microarray.mev.RNASeqSlideData.getCount(RNASeqSlideData.java:29)
      at org.tigr.microarray.mev.cluster.gui.impl.edger.EDGERGUI.execute(EDGERGUI.java:211)
      at org.tigr.microarray.mev.MultipleArrayViewer$7.run(MultipleArrayViewer.java:2625)
      at java.lang.Thread.run(Unknown Source)

      Thanks in advance,
      VP

      ----- Original Message -----

      From: "levk" levk80@users.sf.net
      To: "[mev-tm4:discussion]" 378852@discussion.mev-tm4.p.re.sf.net
      Sent: Friday, February 7, 2014 11:37:41 AM
      Subject: [mev-tm4:discussion] MeV error during startup since Jun 2013

      Should be fixed now, sorry for the delay.

      MeV error during startup since Jun 2013

      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/mev-tm4/discussion/378852/
      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       
      Attachments

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks