MeV won't start

Help
2009-04-28
2013-05-20
  • Guanglei Zhuang

    Guanglei Zhuang - 2009-04-28

    Hi, I have the problem with starting MeV. A black window prompts but shut down quickly. I tried to run it in windows command, and got the message:

    'java' is not recognized as an internal or external command, operable program or batch file.

    Any idea?

     
    • Eleanor Howe

      Eleanor Howe - 2009-04-28

      Hi there,

      It looks like you either don't have Java installed, or Java is not properly set up in your Windows path. You can download Java from Sun's Java website, java.sun.com.

      If you already have Java installed already, then the problem is that Java is not on your windows path. Here's a helpful link on how to do that: http://www.computerhope.com/issues/ch000549.htm

      Eleanor

       
    • Guanglei Zhuang

      Guanglei Zhuang - 2009-04-28

      thanks for the hint.

      I tried to add path to java, but could not figure it out.

      Do you mind to write down a step-by-step instruction?

      Thanks a lot.

       
    • Eleanor Howe

      Eleanor Howe - 2009-04-29
       
    • Glaiza Lyn Tan

      Glaiza Lyn Tan - 2009-06-13

      Hello :) I'm using Acer Aspire One, thus Linux, to start MEV. However, MEV doesn't respond and the following appears in the terminal:

      [user@localhost MEV]$ chmod u+x tmev.sh
      [user@localhost MEV]$ ./tmev.sh
      Exception in thread "main" java.lang.NoClassDefFoundError: org/tigr/microarray/mev/TMEV
      Caused by: java.lang.ClassNotFoundException: org.tigr.microarray.mev.TMEV
              at java.net.URLClassLoader$1.run(Unknown Source)
              at java.security.AccessController.doPrivileged(Native Method)
              at java.net.URLClassLoader.findClass(Unknown Source)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at java.lang.ClassLoader.loadClassInternal(Unknown Source)
      Could not find the main class: org.tigr.microarray.mev.TMEV.  Program will exit.

      I don't know what to do. The instructions I've seen regarding classpath are for Windows and I can't use them on Linux. The tmev.sh is within the MEV folder. And here is the Java version:

      [user@localhost MEV]$ java -version
      java version "1.6.0_13"
      Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
      Java HotSpot(TM) Client VM (build 11.3-b02, mixed mode, sharing)
      [user@localhost MEV]$ which java
      /usr/bin/java

      PLEASE HELP. THANK YOU VERY MUCH!

       
    • Daniel Schlauch

      Daniel Schlauch - 2009-06-15

      Hi,

      It sounds like your unzip utility is not properly unzipping the lib directory.
      Check your lib directory to see if your jar files are there.  You may need to use something else to unzip.

      Dan

       
    • Glaiza Lyn Tan

      Glaiza Lyn Tan - 2009-06-16

      THANK YOU!

      I unzipped the files in another computer and transferred the files to my netbook, and it worked!

      Thank you! :)

       
      • Eleanor Howe

        Eleanor Howe - 2009-06-16

        Hi Glaiza,

        For our information, can you tell us what unzip utility you were using on your netbook? We're going to look into which utilities do and don't work, and try to come up with a compression scheme that will work for everyone.

        Eleanor

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks