Agilent Feature Extraction files

Help
isb666
2009-10-01
2013-05-20
  • isb666

    isb666 - 2009-10-01

    I am having problems loading Agilent Feature Extraction files. Any suggestions?

     
  • Eleanor Howe

    Eleanor Howe - 2009-10-01

    Hi Kathie,

    I'd love to help but I don't know what's wrong. Can you give me some more details?

    Eleanor

     
  • isb666

    isb666 - 2009-10-02

    Hi Eleanor,
    I am trying to load the output file from the Agilent Feature Extraction software (it is a text file) and it does not seem to load properly. I think part of the problem is that the design file from the Agilent website is an .xml file (not text as MeV wants). When I try to save the .xml file as a .txt file there is an error saying it is not the right file (which it is, I checked). When I try to load without a design file the data that gets loaded appears as only a single column in a heatmap.
    Hope that helps,
    thanks
    Kathie

     
  • Eleanor Howe

    Eleanor Howe - 2009-10-02

    Hi Kathie,

    Ok, I have looked at the Agilent file loader and tried a few example files. I'm guessing Agilent has changed their file format again. Would you mind taking a look at the example agilent files that came with your MeV download and seeing if they are anything like the files you have? They should be in the directory MeV_4_4/data/other_format.

    Eleanor

     
  • isb666

    isb666 - 2009-10-02

    Hi Eleanor,
    I looked in the MeV directory and I seem to be missing the "other_format" folder within the data folder. Would it be somewhere else?
    Kathie

     
  • isb666

    isb666 - 2009-10-02

    Hi Eleanor,
    I looked at the sample text file and it does look different than my .txt file from the latest Feature Extraction software although I probably could not give you many specifics.  There are many similarities but the organization of columns is slightly different and things like sequence name/description seem to be missing in my file.  The format of the file makes it difficult to really identify where the differences are but that is what really stood out as being different. Could this be the problem and if so how can i fix this?
    thanks
    kathie

     
  • Eleanor Howe

    Eleanor Howe - 2009-10-03

    Hi Kathie,

    I was afraid of that. The fastest way for you to get your data loaded would be to open up your Agilent file in Excel and move the columns and rows around so that they match the old format. It's irritating, but it should work. You will need to make sure that both the data file and the Agilent design file are in the correct format.

    Another option would be to check the Agilent Feature Extraction software you are using could be made to output a different file format, such as a tab-delimited multiple sample file or a MAGE-TAB file. MeV can load those as well.

    I'm going to create a feature request for the new Agilent file format and put it in place for MeV v4.6, due out next May. I'm afraid we're not going to have time to do it before then. Can you let me know if you have any luck with the options I've suggested?

    Eleanor

     
  • Patrick De Boever

    Hi Kathie, Hi Eleanor,

    I followed yoyr discussion and wondered if you manage to load feature extraction files (we have Agilent FE 10.5). If so, in which format. Also, what does TM4 extract as data from the FE-file? ProcessedSignal? Mean? Median?

    I appreciate your feedback,

    Patrick De Boever

     
  • Eleanor Howe

    Eleanor Howe - 2010-01-26

    Hi Patrick,

    Sarita Nair is working on updating the Agilent file loader to support the latest file formats. We expect to have that available when MeV v4.6 comes out in May, though she may post a snapshot to test with earlier. In the meantime, you may want to try converting your data to a tab-delimited multiple sample file format, as described in the appendix of the MeV manual. I'm not sure exactly what MeV extracts from the Agilent file, so I'll have to ask Sarita.

    Eleanor

     
  • Sarita Nair

    Sarita Nair - 2010-02-03

    Hi Patrick and Kathie,

    Would you mind sending us (mev@jimmy.harvard.edu) the first 50 lines of your Agilent feature extraction file and pattern file?
    We are in the process of updating the Agilent file loader and would appreciate your help.

    Thanks,
    Sarita

     
  • Radhika Anoop

    Radhika Anoop - 2010-03-31

    Hi Sarita, I am radhika from CCMb hyderabad. I am also experiencing the same problems said above with Feature extraction files of Agilent. Can you pls tell me how to upload the pattern file and the array in to MeV for cluster analysis?

     
  • Sarita Nair

    Sarita Nair - 2010-03-31

    Hi Radhika,

    We do plan on addressing this issue in MeV version 4.6 which will be released in June. There will be a new Agilent two color array loader compatible with Agilent FE 10.7. The current loader unfortunately is not capable of loading the new formats and I do not have a quick fix solution for you.

    Thanks for your patience,
    Sarita

     
  • Jann

    Jann - 2010-09-08

    Hi

    I am experiencing similar problems:
    I am trying to load raw data (txt files) from agilent single colour arrays into mev. Mev loader fails to load without giving any error message, express converter reports :
    US91803681_251505810085_S01_GE1_105_Dec08_1_1.txt might be an output of new version of ScanArray. Please report this to the ExpressConverter developers.
    I compared my files to the given example finding different order of colums, additional colums and colums missing. Any attempt of reorganisation failed with error message reporting missing colums.

    Any usefull suggestions would be much appreciated.

    Thanks
    Jann

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks