giuseppe aprea - 2011-10-13

Here a few hints for some issues related to getting MeV working on linux 64 bit platforms. I am just putting together some pieces of solution I collected in different places. It may be useful.

1) I had a problem with edgeR module which made the application creshed. I solved this by recompiling R sources with -m32 flag (just add this flag to environmental variables CFLAGS, FFLAGS and LDFLAGS). You will need 32 bit versions of some gcc libraries (i.e libgfortran); I had them from gcc compilation but I guess you can apt-get them in some way. When recompiling R, remember to use configure option -enable-R-shlib to create an R shared library otherwise MeV can't use R modules (of course you will later need to set LD_LIBRARY_PATH in your environment accordingly and also change R_HOME, R_SHARE_DIR and R_INCLUDE_DIR in

2)I also had a problem with Mev modules using JAVA3D; I solved this problem by changing something in the script. The first problem was to make Mev find the right JAVA3d module BEFORE the other ones which ships with Mev itself (subfolder lib); you can do that in several ways but I followed the suggestion to change the line

After that you get Mev find the right version of JAVA3D but THAT'S NOT ENOUGH since, even if you set LD_LIBRARY_PATH in the right way, Mev is not able to use those shared library which ship with JAVA3D. You can solve that in 2 ways, one is by moving java3d jar files and .so libraries inside the main java folder:

j3dcore.jar, j3dutils.jar, vecmath.jar ==> /jre/lib/ext, ==> jre/lib/i386

but I choose to update the -Djava.library.path=lib option in the last java command in

-Djava.library.path=lib ==> -Djava.library.path=lib:path_to_java3d_shared_object_dir

Of course I am using 32 bit version for both java e java3d.

Good luck!