#4 0.6 fails to compile

closed
nobody
None
5
2005-04-08
2005-03-24
blaster999
No

It fails saying:

metabar_widget.cpp: In member function `void
MetabarWidget::slotRunDesktopFile(const
QString&)':
/usr/kde/3.4/include/kservice.h:522: error:
`KService::KService(const KService&)' is private
metabar_widget.cpp:766: error: within this context

Using KDE 3.4.0, gcc-3.4.3

Discussion

  • Nobody/Anonymous

    Logged In: NO

    looks like ARCH Linux ?
    I got a working one if you want the build let me know

     
  • Mario Vazquez

    Mario Vazquez - 2005-03-25

    Logged In: YES
    user_id=1159112

    I'm using Arch and I'm having the same issue. If you
    have a fixed version, or can share how you fixed I would
    really appreciate it.

     
  • blaster999

    blaster999 - 2005-03-25

    Logged In: YES
    user_id=1080146

    No I am using Gentoo.
    IMO, it looks like the error is caubsed by an API change
    in 3.4

     
  • Nobody/Anonymous

    Logged In: NO

    hi,
    you can download it here :

    http://never.kicks-ass.org/metabar-0.6-1.pkg.tar.gz
    you can use it its work for me or just wait for a fix :)
    (NOTE: it is only my home server and not so fast :P)

    blaster99 you are right :

    kservice.h line 521 , 522 , 532

    private:
    KService( const KService& ); // forbidden
    KService& operator=(const KService&);

     
  • Nobody/Anonymous

    Logged In: NO

    blah should be line 523 :) and not 532

     
  • FlorianJRoth

    FlorianJRoth - 2005-03-29

    Logged In: YES
    user_id=1222958

    In fact this error is caused by an API change in 3.4.
    New versions will fix this, but I have to find a way to make
    it still work for KDE versions older than 3.4

     
  • FlorianJRoth

    FlorianJRoth - 2005-04-08
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks