#25 Problems with Camera Mutual information

v1.0_(example)
open
nobody
None
1
2012-10-15
2012-10-15
gianluca
No

Dear Support,
I tried several time and from different computer to improve the mesh color by importing a raster and aligning it up with the mesh itself.
Here the steps:
Load the ply mesh
import the raster
Show current raster mode
Ctrl H for first adjustment
Filter camera alignment
Get shot
Apply
... and than the model disappears, so I have no way to check if the orientation is ok!
Of course if I press Ctrl H, this will reset the model view to its default and I have to start everything again.
Where is my error? One of the 3 computers I used has a very good NVidia graphic card and RAM, so I don't think it's a memory issue.
Best,
Gianluca

Discussion

  • Matteo Dellepiane

    Hi,
    One reason could be that near and far planes have been wrongly calculated.
    Without moving the model, just increase them (ctrl+wheel for near, ctrl+shift+wheel for far) and the model should appear in the aligned position (or in the position estimated by the filter).
    The procedure is also shown in the video tutorial about raster layers.

     
  • gianluca

    gianluca - 2012-10-15

    Ok, thanks. I will try that.
    I was also wondering if there is a way to register the raster to its position knowing its coordinate and some more parameters. Indeed most of the times I work with photogrammetric pointcloud, and the photogrammetric software provides me with the camera position and orientation. I was wondering if I could use that information for an easier positioning and alignment of raster and model.
    Thanks again

     

Log in to post a comment.