Fill hole operation crashes meshlab

  • Felix Wolfheimer

    I'm currently facing the following problem: I'm trying to use some objects for
    which I have data in the form of stl and obj files within a simulation
    program. In order for the simulation to work the simulation program must be
    able to recognize that the stl/obj files describe a solid (consistent face
    orientation, no holes). However, typically the meshes of the models are broken
    in the sense that they have small holes for example. I found the nice meshlab
    tool (very nice user interface by the way!) and tried to use it to heal the
    meshes and fill the holes they have but it seems that meshlab crashes
    everytime I use the healing operations. So I wonder if I'm missing something
    or if the operation is somehow to complicated. You can reproduce the problem
    using the following model:

    You can do the following:
    Import the mesh. Select the "Fill holes" function and select some of the
    wholes. As soon as you press fill and then "accept" meshlab will crash with an
    assertion failure:

    meshlab: fgtHole.h:472: void FgtHole<MESH>::getPatchFaces(int) : Assertion
    »pos.f->IsUserBit(patchFlag)« failed.

    Does anyone has similar problems or an idea what I'm doing wrong?

    Thanks for your help!

  • Guido Ranzuglia

    Guido Ranzuglia - 2011-03-22

    Sorry but the mesh you have uploaded has not holes...have you downloaded the
    last MeshLab's version?
    In any case fill holes plugin is infamously known to be one of the most crash
    prone. So I can easily believe you have this kind of problems!

  • Felix Wolfheimer

    Hi, thanks for your reply. I've downloaded meshlab 1.3.1 for Windows and I
    also built it from source on a Linux box just to be sure that the problems are
    not some Windows speciality. Regarding the mesh you find on the link above:
    Yes, it seems to have no holes but when you click on the "Fill Holes" button
    in the toolbar a dialog comes up which lists about 150 holes in the mesh.
    Actually they are not really "visible" in the 3D view but somehow artifacts
    probably caused by the way data is stored by obj. When I try to merge nearby
    points the situation gets slightly better and the number of found holes
    decreases a bit but for the remaining holes meshlab crashes anyway.
    I have a lot of problems with this kind of holes as any program which tries to
    interpret such an object as a solid refuses to work. I even tried to remesh
    the object using the different algorithms available in meshlab but this seems
    to crash meshlab as well. Do you have any idea what I could try to get rid of
    those artifacts?

  • Felix Wolfheimer

    Sorry, the meshlab version is 1.3.0a of course. So the latest version you can
    download here.

  • Guido Ranzuglia

    Guido Ranzuglia - 2011-03-22

    This is really strange because every time I click on the Fill hole button
    using this mesh a dialog appears saying "Mesh has not holes to edit". Which
    version of Windows operating system are you using?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks