You can try to update your xserver to latest version.

git clone git://anongit.freedesktop.org/git/xorg/xserver

cd xserver

./autogen.sh -with-mesa-source=$YOUR_MESA_SOURCE

make

make install

 

Nian


From: mesa3d-users-bounces@lists.sourceforge.net [mailto:mesa3d-users-bounces@lists.sourceforge.net] On Behalf Of tran huy hoang
Sent: 2006
923 10:23
To: Brian Paul
Cc: mesa3d-users@lists.sourceforge.net
Subject: Re: [Mesa3d-users] mesa compile problem

 

Hi Bian,
 Yes I have done the "make realclean " before compiling it. And the error looks like :
gcc -I../../include -Wall -Wmissing-prototypes -O3 -g -fPIC  -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_XSHM -DHAVE_POSIX_MEMALIGN -DUSE_MGL_NAMESPACE -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM -I/usr/X11R6/include -std=c99 -ffast-math -DUSE_MGL_NAMESPACE arbfplight.c readtex.o -L../../lib -lMesaglut -lMesaGLU -lMesaGL -lm -o arbfplight
../../lib/libMesaGL.so: undefined reference to `_glapi_Dispatch'
collect2: ld returned 1 exit status
make[3]: *** [arbfplight] Error 1
make[3]: Leaving directory `/usr/local/Mesa-6.5.1/progs/demos'

I wonder if the new version has bug because it seems to have no problem with an older version.
thank you for reading

Brian Paul <brian.paul@tungstengraphics.com> wrote:

tran huy hoang wrote:
> hi,
> I am using the latest version 6.5.1 and trying to
> make with linux-x86 configs. I have added to CFLAGS
> and CXXFLAGS the option -DUSE_MGL_NAMESPACE (I did it
> in configs/linux) and there is an error says
> " ../../lib/libMesaGL.so: undefined reference to
> '_glapi_Dispatch' "

I just tried USE_MGL_NAMESPACE and it worked for me.

Did you do a 'make clean' before compiling?

Otherwise, please post more of the output from before the error so I
know where it's happening.

-Brian

 

 


Do you Yahoo!?
Get on board. You're invited to try the new Yahoo! Mail.