Hi,

I work on Ubuntu 9.04 and I try to compil and install mesa. My PC has a poulsbo chipset, so I have installed the librairies :
    libdrm-poulsbo1 (version 2.3.0)
    libdrm-poulsbo-dev (version 2.3.0)
    libdrm-poulsbo1-dbg (version 2.3.0)

Now, i try to compil libgl1-mesa-dri-psb (version 0.25 - Implementation of the OpenGl API -- for Pouslbo (psb)). But the configure of the libgl1-mesa-dri-psb needs the version 2.3.1 of libdrm. But I don't found libdrm-poulsbo1-2.3.1.

So, I have modified the varaible LIBDRM_REQUIRED (LIBDRM_REQUIRED=2.3.0 #My version of libdrm-poulsbo) of the configure of libgl1-mesa-dri-psb.

I recompile libgl1-mesa-dri-psb, but there is an error :
intel_screen.c:839: erreur: 'I915_PARAM_CHIPSET_ID' undeclared (first use in this function)

How do to succes to compile mesa with a poulsbo chipset ???
Thanks


 

Nicolas Cadio
ENSSAT, EII3
ncadio@enssat.fr
cadio_nicolas@yahoo.fr