SourceForge has been redesigned. Learn more.

Meditomb disappears when used with bridge

  • snoopy

    snoopy - 2012-12-09

    Hi everybody,

    I have this problem:

    I am running Mediatomb on an Ubuntu 12.04.1 LTS Server. As long I was using the network interface normally as eth0 Mediatomb worked fine.

    For using bridged networking in a KVM VirtualMachine I changed using eth0 as bridge with this configuration:

    iface br1 inet static
            bridge_ports eth0
            bridge_stp off
            bridge_waitport 5

    I changed the MediaTomb config so it uses br1 as interface, resulting in this command:

    mediatomb -c /etc/mediatomb/config.xml -u mediatomb -g mediatomb -l /var/log/mediatomb.log -e br1

    The routing table is this:   U     0      0        0 br1       U     0      0        0 br1

    Right after the start of Mediatomb everything works fine, I can see MT in my Media Players and use it normally. But after 10-30 min it suddenly disappears from the network… Whe I stop and start MT again, it appears again for 10-30 min, then it's again gone…

    To test the issue, I removed the bridge and used eth0 again the normal way and Mediatomb stays in the net…

    Has anyone an idea what could be wrong?

    Thx in advance!

  • snoopy

    snoopy - 2012-12-11

    I think I found a possible solution in this thread in a Gentoo - forum:

    There several UPnP / DLNA Servers are mentioned with similar problems when connected to a bridge, what seems to occur since a 3.x Kernel.. for me the mentioned command

    ifconfig br0 allmulti promisc

    solved the issue, so it seems to be a kernel related problem…

  • Anonymous

    Anonymous - 2013-04-22

    Adding promisc and allmulti didnt do the trick on ubuntu 12.04 with 3.5 kernel.

    Resolved by turning on multicast querier on bridge interface:

    echo 1 > /sys/class/net/br0/bridge/multicast_querier


Log in to post a comment.