Mediatomb and OpenVPN

  • heinzlmann

    heinzlmann - 2011-01-05

    Hello anyone,
    I've a Debian Lenny server at home running both, mediatomb and openvpn.
    Now, everytime I start my server and openvpn builds the tun0 interface mediatomb uses the IP of tun0 instead of eth0.
    I tried to change the config file telling mediatomb to use <ip></ip> but it does not change anything.
    Only if I stop openvpn and do a restart of mediatomb it would run well.

    What else can I try to solve that problem?

    Thanks in advance for your answers.

  • astek

    astek - 2012-01-16


    I stumbled upon the same problem. I solved it by starting up mediatomb before openvpn.
    I did that by renaming /etc/rc2.d/S19mediatomb to /etc/rc2.d/S02mediatomb
    The openvpn script was not touched (S03openvpn). Anyway, you want to adjust the
    number in front of mediatomb to be less than the number in front of openvpn.

    ~ Ales

  • astek

    astek - 2012-01-16

    Uf, I just noticed that this is a really old thread. Anyway, I hope it helps someone.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks