SourceForge has been redesigned. Learn more.

Transcoded file mimetype wrong in browse?

  • Michael Whidden

    Michael Whidden - 2011-05-03

    When I browse a video/dvdiso video file with a transcode profile set up, Mediatomb reports to the mediaplayer that the mimetype is video/dvdiso , even though when I actually play the file, the transcode produces mimetype video/mpeg. Shouldn't mediatomb indicate the mimetype is video/mpeg, since that is the type of the stream the media player will be receiving during the transcode?

    Some mediaplayers will not even try to play a file if the mimetype in the BrowseResult is not supported by the player, even though the transcoded mimetype is supported.

          <transcode mimetype="video/dvdiso" using="mencoder-iso"/>

          <profile name="mencoder-iso" enabled="yes" type="external">
            <agent command="/usr/local/bin/mediatomb-mencoder-iso" arguments="%in %o
            <buffer size="1000000" chunk-size="512000" fill-size="20480"/>

    BrowseResult contains: "…protocolInfo=&quot;http-get:*:video/dvdiso:DLNA.ORG_OP=01;DLNA.ORG_CI=0&quot; …"
    I should think the BrowseResult should have video/mpeg, no?

  • BT

    BT - 2011-05-04

    Does adding <hide-original-resource>yes</hide-original-resource> to the mencoder-iso profile help? Without this option, MediaTomb will present both the original and transcoded resources. The UPnP device should then select the resource that it supports, although most UPnP devices will just select the first resource.

  • Christian Blumer

    Hello all,
    Thanks a lot for this post. I had the exact same problem with transcoding file that doesn't appear in my UPNP device.
    Adding <hide-original-resource>yes</hide-original-resource> to the mencoder-iso profile makes all the stuff work fine.
    My UPNP device is a Philips DBP 5100/12 device. I am using ubuntu 10.10 and mediatomb 0.12.1
    Best regards!


Log in to post a comment.