transcoding CR2 to Samsung

Help
Anonymous
2011-03-10
2013-05-30
  • Anonymous - 2011-03-10

    I've been going like crazy trying to be able to view Canon .CR2 photos on my Samsung TV using  mediatomb. Mediatomb is otherwise working great, for all media that is natively supported by the TV.

    I set up transcoding following for example: http://en.gentoo-wiki.com/wiki/MediaTomb#Raw_Images just to use dcraw to extract the jpeg thumb from the CR2.

    I can check that the file is being imported to Mediatomb's database as mimetype image/raw as per-instructions, I also can check that the transcoder produces the right output as in http://mediatomb.cc/pages/transcoding#id2892868 but I still get the "Not supported file format" message.

    Now the weird part: if I run the server on my laptop (Linux amd64) the transcoder wrapper doesn't even get called.

    If I run the server on my wifes (Linux ppc, same configuration than on amd) the wrapper does get called but still the same message. I can check that in this case the transcoder does get called because I can add a line to the wrapper of the form "echo some-string >> somefile" and the file gets written.

    Is there any known bug on mediatomb about this issue? (I couldn't find anything here and all sites seem to imply that cr2 rendering should be straightforward!)

    My logs don't show anything relevant. Just the typical:

    ERROR: ActionRequest::update(): response is nil, code -115

    which is unrelated.

    I'd appreciate any idea.

    R.

     
  • Anonymous - 2011-03-10

    Well, just to add to this topic, I managed to get the jpeg thumbnail to be served without any luck on the tv side (same error message). The wireshark log (should filter http) is on http://www.sendspace.com/file/rbyed5. The size of the file matches the jpg extraced thumb. I don't know why it's not showing though.

    R.

     
  • Anonymous - 2011-03-10

    Success! I realized that serving an actual jpeg the picture is not chunked, so I added <use-chunked-encoding>no</use-chunked-encoding> to the transcoding profile and that worked fine.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks