TagLib Detection Issue When Compiling SVN

Help
boilerjt
2008-09-27
2013-05-30
  • boilerjt

    boilerjt - 2008-09-27

    Jin,

    I can now compile SVN code directly on my DNS-323 NAS :)  I am seeing one issue where TagLib seems to be detected in the configure process, but says it is missing in the configure summary and does not build with it.

    checking for taglib-config... /opt/bin//taglib-config
    checking taglib cflags... -I/opt/include/taglib
    checking taglib libs... -L/opt/lib -ltag
    checking taglib.h usability... yes
    checking taglib.h presence... yes
    checking for taglib.h... yes
    checking fileref.h usability... yes
    checking fileref.h presence... yes
    checking for fileref.h... yes
    checking tag.h usability... yes
    checking tag.h presence... yes
    checking for tag.h... yes

    CONFIGURATION SUMMARY ----

    sqlite3               : yes
    mysql                 : missing
    libjs                 : missing
    libmagic              : yes
    inotify               : missing
    libexif               : missing
    id3lib                : disabled
    taglib                : missing
    libmp4v2              : missing
    ffmpeg                : missing
    ffmpegthumbnailer     : missing
    external transcoding  : yes
    curl                  : missing
    YouTube               : missing
    SopCast               : disabled
    libextractor          : disabled
    db-autocreate         : yes

    Also, the configuration detected the system as armv5tejl-unknown-linux-gnu.  Will you have a static binary for this?

    Thanks,
    John

     
    • Jin

      Jin - 2008-09-27

      Compiling on the NAS? That surely takes a while... :)

      Please email me the config.log, I'll have a look.

       
    • boilerjt

      boilerjt - 2008-09-27

      It takes about 2 hours to compile, so it is doable.  The most difficult thing was getting autoreconf to work.  The initial results of this first build for the DNS-323 NAS were great.  All of the transcoding worked really well and used less CPU than I anticipated.

      madplay: 14% CPU
      faad: 20% CPU
      flac 8% CPU
      oggdec 14-26% CPU

      If I get taglib, spidermonkey, and libmp4v2 to work, I'll have everything I need.  I'll email the config.log file to you.

       
    • boilerjt

      boilerjt - 2008-09-28

      I got it working.  It seems that some dependencies in Optware were compiled with a hardware floating point, where the NAS only has software emulation. This will cause errors.  After compiling taglib on the NAS, it worked.  I also built spidermonkey (which was a pain), libmp4v2, libexif, and curl and successfully built MediaTomb SVN 1895.

      One word of warning before trying to build MediaTomb on a NAS... set the $TMPDIR environmental variable before starting the build.  If it is not assigned, /tmp will be used.  On my NAS, /tmp is on the DiskOnChip and has very little extra space.  The compilation crapped out with an out of space error  I had to set $TMPDIR to a directory on one of the hard drives and it compiled successfully.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks