Transcoding problem with ogg-files

  • Bernd Seyerlein

    Bernd Seyerlein - 2011-01-25


    I run Mediatomb 0.12.0  (Debian package) on a sheevaplug. When transcoding ogg files, the first second of the track is ok but after that all I can hear is noise. I tried it on a Pinnacle SoundBridge and on a Windows netbook (Windos Media Player). The result is the same on both devices.

    Here's the transcoding section of my config.xml:

      <transcoding enabled="yes">
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2ROKU-Format"/>
          <transcode mimetype="audio/x-flac" using="oggflac2ROKU-Format"/>
          <profile name="oggflac2ROKU-Format" enabled="yes" type="external">
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
            <agent command="ogg123" arguments="-d raw -o bydeorder:big -f %out %in"$
          <profile name="vlcmpeg" enabled="no" type="external">
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffm$
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>

    I took the transcoding profile from the forum here. I hope anyone has an idea where to tweak the config file.

    Thanks in advance.


  • BT

    BT - 2011-01-25

    Try changing the byteorder argument to little for the oggflac2ROKU-Format profile.

  • Bernd Seyerlein

    Bernd Seyerlein - 2011-01-26

    Forgot to mention that I tried both options: big and little. The result is the same on both settings.

  • Bernd Seyerlein

    Bernd Seyerlein - 2011-01-26

    Just noticed that there is a typing error in the byteorder-argument.

    Corrected it but still no progress.



Log in to post a comment.