Mediatomb on ix2-200 nas: dependency problem

  • Pol

    Pol - 2011-05-29

    I have installed mediatomb on my ix2-200 nas, and at first everything worked. Than i started to fiddle with a scripted interface, and it looked great. Finally, i wanted to make a deamon from mediatomb, to make it run automatically at boot of the nas.

    This is where things went wrong: After converting to a deamon, everyting worked. When i rebooted the nas, MT didn't boot. When i tried to boot it by hand, it gave an error: /opt/bin/mediatomb: error while loading shared libraries: cannot open shared object file: No such file or directory failed
    But there is a file on my nas (/mnt/soho_storage/opt/ipkg/lib/

    By the way, i used a precompiled version of mediatomb, as can be found in

    Is there a way to point mediatomb to the right directory or where do i have to place, so mediatomb can find it?

    Thanks a lot!

  • Pol

    Pol - 2011-05-31

    I've got it running again finally. After a few cycles of removing/rebooting/reinstalling/other ipkg options, I ended up again with a freshly installed version. It ran again without problems. After converting it back into deamon mode, it ran "without" problems.


Log in to post a comment.