SRT transcoding

Help
chiarac
2012-10-27
2013-05-30
  • chiarac

    chiarac - 2012-10-27

    Hi!
    I\\\'m trying o have mediatomb share subtitles through DLNA, so I can watch subbed videos on my tablet
    I followed this guide mediatomb.cc/dokuwiki/transcoding:transcoding
    but still it\\\'s not working

     
  • chiarac

    chiarac - 2012-10-27

    here is my config:

      <server>
        <ui enabled=\"yes\" show-tooltips=\"yes\">
          <accounts enabled=\"no\" session-timeout=\"30\">
            <account user=\"mediatomb\" password=\"mediatomb\"/>
          </accounts>
        </ui>
        <name>MediaTomb</name>
        <udn>uuid:d3b8dfcd-b46d-40c6-9e38-ca43c1d7f631</udn>
        <home>/home/chiara/.mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage>
          <sqlite3 enabled=\"yes\">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
          <mysql enabled=\"no\">
            <host>localhost</host>
            <username>mediatomb</username>
            <database>mediatomb</database>
          </mysql>
        </storage>
        <protocolInfo extend=\"no\"/><!- For PS3 support change to \"yes\" ->
        <!-
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        ->
        <!-
        <custom-http-headers>
          <add header=\"X-User-Agent: redsonic\"/>
        </custom-http-headers>

        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        ->
        <!- Uncomment the line below if you have a Telegent TG100 ->
        <!-
           <upnp-string-limit>101</upnp-string-limit>
        ->
        <extended-runtime-options>
          <ffmpegthumbnailer enabled=\"no\">
            <thumbnail-size>128</thumbnail-size>
            <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
            <image-quality>8</image-quality>
          </ffmpegthumbnailer>
          <mark-played-items enabled=\"no\" suppress-cds-updates=\"yes\">
            <string mode=\"prepend\">*</string>
            <mark>
              <content>video</content>
            </mark>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <import hidden-files=\"no\">
        <scripting script-charset=\"UTF-8\">
          <virtual-layout type=\"builtin\"/>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown=\"no\">
            <map from=\"mp3\" to=\"audio/mpeg\"/>
            <map from=\"ogx\" to=\"application/ogg\"/>
            <map from=\"ogv\" to=\"video/ogg\"/>
            <map from=\"oga\" to=\"audio/ogg\"/>
            <map from=\"ogg\" to=\"audio/ogg\"/>
            <map from=\"ogm\" to=\"video/ogg\"/>
            <map from=\"asf\" to=\"video/x-ms-asf\"/>
            <map from=\"asx\" to=\"video/x-ms-asf\"/>
            <map from=\"wma\" to=\"audio/x-ms-wma\"/>
            <map from=\"wax\" to=\"audio/x-ms-wax\"/>
            <map from=\"wmv\" to=\"video/x-ms-wmv\"/>
            <map from=\"wvx\" to=\"video/x-ms-wvx\"/>
            <map from=\"wm\" to=\"video/x-ms-wm\"/>
            <map from=\"wmx\" to=\"video/x-ms-wmx\"/>
            <map from=\"m3u\" to=\"audio/x-mpegurl\"/>
            <map from=\"pls\" to=\"audio/x-scpls\"/>
            <map from=\"flv\" to=\"video/x-flv\"/>
            <map from=\"mkv\" to=\"video/x-matroska\"/>
            <map from=\"mka\" to=\"audio/x-matroska\"/>
    <map from=\"srt\" to=\"video/subtitle\"/>
            <!- Uncomment the line below for PS3 divx support ->
            <!- <map from=\"avi\" to=\"video/divx\"/> ->
            <!- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 ->
            <!- <map from=\"avi\" to=\"video/avi\"/> ->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from=\"audio/*\" to=\"object.item.audioItem.musicTrack\"/>
            <map from=\"video/*\" to=\"object.item.videoItem\"/>
            <map from=\"image/*\" to=\"object.item.imageItem\"/>
            <map from=\"application/ogg\" to=\"object.item.audioItem.musicTrack\"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype=\"audio/mpeg\" as=\"mp3\"/>
            <treat mimetype=\"application/ogg\" as=\"ogg\"/>
            <treat mimetype=\"audio/x-flac\" as=\"flac\"/>
            <treat mimetype=\"image/jpeg\" as=\"jpg\"/>
            <treat mimetype=\"audio/x-mpegurl\" as=\"playlist\"/>
            <treat mimetype=\"audio/x-scpls\" as=\"playlist\"/>
            <treat mimetype=\"audio/x-wav\" as=\"pcm\"/>
            <treat mimetype=\"audio/L16\" as=\"pcm\"/>
            <treat mimetype=\"video/x-msvideo\" as=\"avi\"/>
            <treat mimetype=\"video/mp4\" as=\"mp4\"/>
            <treat mimetype=\"audio/mp4\" as=\"mp4\"/>
            <treat mimetype=\"application/x-iso9660\" as=\"dvd\"/>
            <treat mimetype=\"application/x-iso9660-image\" as=\"dvd\"/>
            <treat mimetype=\"video/x-matroska\" as=\"mkv\"/>
            <treat mimetype=\"audio/x-matroska\" as=\"mka\"/>

          </mimetype-contenttype>
        </mappings>
        <online-content>
          <YouTube enabled=\"no\" refresh=\"28800\" update-at-start=\"no\" purge-after=\"604800\" racy-content=\"exclude\" format=\"mp4\" hd=\"no\">
            <favorites user=\"mediatomb\"/>
            <standardfeed feed=\"most_viewed\" time-range=\"today\"/>
            <playlists user=\"mediatomb\"/>
            <uploads user=\"mediatomb\"/>
            <standardfeed feed=\"recently_featured\" time-range=\"today\"/>
          </YouTube>
        </online-content>
      </import>
      <transcoding enabled=\"yes\">
        <mimetype-profile-mappings>
          <transcode mimetype=\"video/x-flv\" using=\"vlcmpeg\"/>
          <transcode mimetype=\"application/ogg\" using=\"vlcmpeg\"/>
          <transcode mimetype=\"application/ogg\" using=\"oggflac2raw\"/>
          <transcode mimetype=\"audio/x-flac\" using=\"oggflac2raw\"/>
    <transcode mimetype=\"video/subtitle\" using=\"mencoder-srt\"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name=\"oggflac2raw\" enabled=\"no\" type=\"external\">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command=\"ogg123\" arguments=\"-d raw -o byteorder:big -f %out %in\"/>
            <buffer size=\"1048576\" chunk-size=\"131072\" fill-size=\"262144\"/>
          </profile>
          <profile name=\"vlcmpeg\" enabled=\"no\" type=\"external\">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command=\"vlc\" arguments=\"-I dummy %in -sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit\"/>
            <buffer size=\"14400000\" chunk-size=\"512000\" fill-size=\"120000\"/>
          </profile>
    <profile name=\"mencoder-srt\" enabled=\"yes\" type=\"external\">
    <mimetype>video/mpeg</mimetype>
    <agent command=\"/usr/local/bin/mediatomb-mencoder-srt\" arguments=\"%in %out\"/>
    <buffer size=\"14400000\" chunk-size=\"512000\" fill-size=\"120000\"/>
    <first-resource>yes</first-resource>
    </profile>
        </profiles>
      </transcoding>
    </config>

     
  • chiarac

    chiarac - 2012-10-27

    as dlna client I tried both the built in samsung app and MediaHouse

    sorry for the delayed postings, but the system kept saying my content looked like spam, so I had to try multiple times

    thank you very much for any help!

     
  • chiarac

    chiarac - 2012-10-27

    Hi everybody, sorry for the useless post: I solved the previous issue following this thread https://sourceforge.net/projects/mediatomb/forums/forum/440751/topic/3245305
    basically I had to remove all newlines from the mencoder part of mediatomb-mencoder-srt
    and I had to change some options.
    these work:
    exec mencoder "$input" -oac lavc -ovc lavc -of mpeg -lavcopts vcodec=mpeg2video:keyint=250:vbitrate=9800:vrc_maxrate=9800:vrc_buf_size=1835 -vf harddup -mpegopts muxrate=12000 -fps 24 -sub "$srt" -font "/usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf" -o "$output"

    hope to be useful to someone, sorry for the misuse of the forum

    bye!

     
  • Zlatko Kostadinov

    How do you know the command was executed. For me it looks like /usr/local/bin/mediatomb-mencoder-srt, or whatever I put there, was not called at all.

     
  • chiarac

    chiarac - 2012-11-26

    I start mediatomb from shell, and I see mencoder debug info when I start streaming

    FYI the framerate I posted is still not good, sound gets delayed after some minutes, I still haven't found the best setting

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks