filename-charset ISO-8859-15 possible?

Help
airflow
2007-09-23
2013-05-30
  • airflow

    airflow - 2007-09-23

    Hi,

    I seem to have problems with the character-encoding settings in mediatomb (0.11.0-pre). I use a debian-server which uses ISO for encoding of the filesystem. The MP3s themselves are encoded with ID3v2.3 Tags with UTF-16 encoding. So I set the following:

    <filesystem-charset>ISO-8859-15</filesystem-charset>
        <metadata-charset>UTF-16</metadata-charset>

    Interestingly, when I now browse my filesystem over the html-interface from mediatomb, I see corrupted character-decoding for Umlauts in directorynames, while the names of the files themsselves are displayed correctly (they use of course the same filesystem-character-encoding). Please note that I'm not speaking of the metadata within those mp3s, just the names of files and directories.

    For a test, I tried to switch UTF-8 and UTF-16 for filesystem-charset (although I knew I use the ISO-variant), and in these cases both, files and directories, are displayed incorrectly (as I would expect it :))..

    So is this a bug in mediatomb, or could I try out something else?

    Thanks for your opinion,
    airflow

     
    • Jin

      Jin - 2007-09-24

      I can only suggest the following:
      >
      go to a directory that contains the files that are displayed incorrectly, do an "ls >/tmp/test.txt", now you have a testfile to play with. Use iconv to figure out the encoding, however make sure that you have an UTF-8 capable editor when you view the result; try converting the test.txt file into UTF-8, for example: cat test.txt | iconv -f ISO-8859-15 -t UTF-8 > /tmp/result.txt

      The "to" has always to be UTF-8, thats what we use internally, the from can vary depending on the source encoding; I believe that you will get the same results as in MediaTomb - we also use iconv to convert a string from some encoding to UTF-8.

      Allthough your system locale might be set to ISO-8859-15, are you sure that those particular files are named according to that charset? Are they displayed correctly, when you simply do "ls" in the terminal? Compare that to what you see in the MediaTomb web UI, would be interesting, especially thsii filename/directory name thing that you mentioned.

      Kind regards,
      Jin

       
    • airflow

      airflow - 2007-09-24

      Hi Jin!

      I'm fairly sure it's not an encoding-problem of the filesystem itself. I still tried the conversion-test with iconv you suggested. The resulting file was displayed correctly with gedit (of Gnome). I think it's probably a mere problem of how mediatomb creates the HTML-pages.

      Please have a look at the screenshots, perhaps the problem gets more obvious then:
      http://fp.ath.cx/mt1.png
      http://fp.ath.cx/mt2.png

      While in the first picture you can see that on the bash (via ssh) everything is displayed correctly, in the second screenshot you see the bad encoding on the upper right. By the way, in the directory-tree on the left the strings are displayed correctly! I also tried playing with the settings of firefox, but also without luck. Analysing of the HTML-code didn't help, because I couldn't find the string in the source of the frame.

      Kind regards,
      airflow

       
    • Jin

      Jin - 2007-09-25

      OK, I think I get the idea now. Originally I thought that it's wrong everywhere (i.e. UI and UPnP), so its only about the upper right string? We will take a look at it, I think it should be easy to fix, thanks!

      Kind regards,
      Jin

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks