Samsung + mediatomb another time

Help
dJabber
2012-04-21
2013-05-30
  • dJabber

    dJabber - 2012-04-21

    hello. I got samsung TV 2012 year model - UE32ES5500. Mediatomb doesn't play on it (even it doesn't show films list on mediatomb server), but the same mediatomb plays good on TV 2011 year model - UE40D5800.
    I discovered, that UE32ES5500 requests  "transferMode.dlna.org : interactive" from mediatomb server, but mediatomb closes connection on this request. How can I solve this problem? How can I make mediatomb to work in "transfermode interactive"?

     
  • arjan ten hoopen

    Add the following lines to config.xml. Worked for me

    <custom-http-headers>
      <!- Samsung needs it ->
      <add header="transferMode.dlna.org: Streaming"/>
      <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000"/>
    </custom-http-headers>

    Cheers,
    Arjan

     
  • dJabber

    dJabber - 2012-04-23

    I already tried this:

        <custom-http-headers>
            <add header="X-User-Agent: redsonic"/>
            <add header="transferMode.dlna.org: Streaming" />
            <add header="contentFeatures.dlna.org:DLNA.ORG_OP=00;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=01700000000000000000000000000000" />
        </custom-http-headers>
    

    and this one

        <custom-http-headers>
            <add header="X-User-Agent: redsonic"/>
            <add header="transferMode.dlna.org: Streaming" />
            <add header="contentFeatures.dlna.org:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000" />
        </custom-http-headers>

     
  • Lazar Florentin

    Lazar Florentin - 2012-04-26

    I have problems in playing content on a samsung 40D5000, i get this error:
    ERROR: ActionRequest::update(): response is nil, code -115

    I've tried all the methods found on the wiki but without luck… :(

     
  • arjan ten hoopen

    Did you actaully try my code, it worked for me!!

     
  • Anonymous - 2012-05-25

    The code you gave *will* let Samsung TVs (2011's 6500 model) play videos.  But the problem we're seeing in the 2012 models is media tomb doesn't even give a listing of files - we never even get to the point of playing anything.

    Any ideas?

     
  • Anonymous - 2012-05-25

    OK I have more info now.  My the mediatomb server I ran \\\"tcpdump host 10.6.0.60 -A -w sam.txt\\\" just before I clicked on \\\"MediaTomb\\\" from the AllShare (DLNA) menu.
      - 10.6.0.60 is the IP of my TV and sam.txt is the file where the captured the dump

    Request:

    POST //upnp/control/cds HTTP/1.1
    Accept: */*
    User-Agent: SEC_HHP_[TV]UN55ES6100/1.0 DLNADOC/1.50
    Host: 10.6.0.2:50500
    SOAPACTION: \\\"urn:schemas-upnp-org:service:ContentDirectory:1#X_GetFeatureList\\\"
    CONTENT-TYPE:  text/xml; charset=\\\"utf-8\\\"
    Content-Length: 291
    Connection: close
    <?xml version=\\\"1.0\\\" encoding=\\\"utf-8\\\"?><s:Envelope s:encodingStyle=\\\"hxxp://schemas.xmlsoap.org/soap/encoding/\\\" xmlns:s=\\\"hxxp://schemas.xmlsoap.org/soap/envelope/\\\"><s:Body><u:X_GetFeatureList xmlns:u=\\\"urn:schemas-upnp-org:service:ContentDirectory:1\\\"></u:X_GetFeatureList></s:Body></s:Envelope>
    

    Response:

    HTTP/1.1 500 Internal Server Error
    CONTENT-LENGTH: 411
    CONTENT-TYPE: text/xml; charset=UTF-8
    DATE: Fri, 25 May 2012 15:44:08 GMT
    EXT:
    SERVER: Linux/2.6.43.2-6.fc15.x86_64, UPnP/1.0, MediaTomb/0.12.1
    CONNECTION: close
    transferMode.dlna.org: Streaming
    contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000
    <s:Envelope xmlns:s=\\\"hxxp://schemas.xmlsoap.org/soap/envelope/\\\" s:encodingStyle=\\\"hxxp://schemas.xmlsoap.org/soap/encoding/\\\">
    <s:Body>
    <s:Fault>
    <faultcode>s:Client</faultcode>
    <faultstring>UPnPError</faultstring>
    <detail>
    <UPnPError xmlns=\\\"urn:schemas-upnp-org:control-1-0\\\">
    <errorCode>-1</errorCode>
    <errorDescription>Invalid Action</errorDescription>
    </UPnPError>
    </detail>
    </s:Fault>
    </s:Body>
    </s:Envelope>
    

    Running mediatomb with /etc/mediatomb.conf MT_OPTIONS=\\\"-D\\\" doesn\\\'t show anything.

    Hope this helps!!!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks