PS3 now suports divx

Help
romeyde
2007-12-18
2013-05-30
  • romeyde

    romeyde - 2007-12-18

    I just picked up a PS3 yesterday and I'm trying to use it to watch movies streamed from a ubuntu box using MediaTomb.  Out of the 30 or so sample files, only 1 shows up on the ps3 as supported.  Most of these videos are simply downloaded tv shows.  I believe (maybe wrong) that I just need to tell tell MediaTomb to report the xvid files as divx files.  Has anyone tried this yet (at work, can't try myself at the moment).  What would I put in the config.xml to try this?  I think this would work because from the reports I've been seeing, the majority of xvid files work but only when played locally on the ps3 on a burned dvd or from a USB mem stick.

     
    • Jin

      Jin - 2007-12-18

      Add the following mapping to the extension-mimetype section of your config.xml:

      <map from="avi" to="video/divx"/>

      restart the server, reimport the media in question; should work after that :>

       
    • Simon Bowen

      Simon Bowen - 2007-12-18

      Hi

      I just got mine working with the line

      <map from="avi" to="video/x-divx"/>

      I am now watching Gladiator off my linux box, how do you easily reimport media?!

       
    • ear

      ear - 2007-12-18

      Worked for me to.  Thanks much.

      Not sure how to "reimport" but I set mine to rescan every 30 minutes.   I assume this is to look for new files.  Doing that seemed to take care of the reimport thing also.

       
    • Jin

      Jin - 2007-12-19

      reimport means: remove the files from the database (using the linked remove icon, the x with the chains) and add the data again.

      rescanning indeed looks for new files, but it will not touch old ones, so if you want your all ones to be imported with the newly specified mimetype you will have to reimport manually

       
    • Robert

      Robert - 2007-12-20

      Follow this guide as there is an important step I missed:

      http://forums.fedoraforum.org/showthread.php?p=924980

      "ow we just need to make a two minor changes to the config file so the PS3 can see the avi files. Lets edit the config.xml file
      Code:

      nano /etc/mediatomb/config.xml

      Find the line near the top called <server> and add underneath <protocolInfo extend="yes"/>

      It should look like this
      <server>
      <protocolInfo extend="yes"/>

      Now scroll down the rest of the configuration file and find
      <mappings>
      <extension-mimetype ignore-unknown="no">

      Add the following to the list of others
      <map from="avi" to="video/avi"/>

      Now restart mediatomb "

       
    • redcap

      redcap - 2007-12-20

      So I'm a bit confused, and I can test it either because I can only open my PS3 present at Christmas ;-)
      Should I add:
      <map from="avi" to="video/avi"/> or <map from="avi" to="video/x-divx"/>

       
    • Jin

      Jin - 2007-12-20

      The mapping <map from="avi" to="video/x-divx"/> should be enough; also do not forget to add the <protocolInfo extend="yes"/> setting in the server section :>

       
    • redcap

      redcap - 2007-12-27

      Dvix works perfect.
      But now the PS3 doesn't recognize the avi files I made whith my Canon Powershot camera: "unsopported file format" or something similar.
      How can I solve this?

      Like this?
      Change  <map from="avi" to="video/x-divx"/> to <map from="avi" to="video/avi"/> (not sure if this mime type is correct)
      restart Mediatomb and do a rescan of the dir with Canon avi's

      or maybe modify the database directly?
      or something else?

       
    • redcap

      redcap - 2007-12-27

      I modified the mime-type of one file directly via the Mediatomb webinterface (to video/avi) and this works!
      Now I'd like to do this easily for all of my video files (I have a lot) in an easy way.
      Any suggestions? (I don't use mysql)
      Thanks

       
    • redcap

      redcap - 2007-12-27

      I just noticed that when I changes the mimetype in config.xml from "video/x-divx" to "video/avi" (followed by a restart and a rescan)

      The mimetype for dvix files in the database becomes "video/avi" which the PS3 plays correctly ...
      but the mimetype in the database results in video/x-msvideo for my own recorded movies (Canon) which still result in incompatible data on my PS3 :(

       
    • SG_01 Lunarchild

      If you want to change all tags in your library, you could do the following (profided you are using SQLite3, and /etc/mediatomb/mediatomb.db - check your config.xml):

      # /etc/init.d/mediatomb stop
      # cd /etc/mediatomb
      # sqlite3 mediatomb.db
      sqlite&gt; update mt_cds_object set mime_type = 'video/divx' where mime_type = 'video/x-msvideo';
      sqlite&gt; .exit
      # /etc/init.d/mediatomb start

      Note that these commands are launched using root, and are specific to my class of Linux systems, so you may need to find the correct commands for your distribution.

      - SG

       
    • Jin

      Jin - 2007-12-28

      The mappings in config.xml are case sensitive, I guess I will change that soon; your Canon camera probably creagtes .AVI files and there the mapping does not get picked up, so just add another line with the capital .AVI extension.

      Please, do not mess with the database directly!

       
    • redcap

      redcap - 2007-12-28

      To Jin: Ok, indeed my camera creates .AVI files (uppercase).
      The fact that mappings are case sensitive turns out to be in my favour. It works! Thanks.
      Otherwise, it wouldn't be possible to play both dvix and other avis on via Mediatomb, isnn't it?
      At least not without messing around in the database afterwards. Or is there a mimetype which you can use for both?

      To SG_01 Lunarchild: I've chosen the safer method, but thanks for the tip anyway ;)

       
    • Jin

      Jin - 2007-12-28

      Well, you would only have a problem if you wanted to transcode some AVI's but not others - since our transcoding is mimetype oriented. I think the PS3 has some troubles with xvid movies; the mime type does not matter much in that case - it turned out that the decoder will try to play whatever is thrown at it, so the mime type only tells the media browser to accept or reject certain files for playback. So it is my understanding that the PS3 will try to play any content marked with a video/divx mimetype, the success however depends on the codec.

      Anyway, glad to hear that you figured it out :)

       
    • Jin

      Jin - 2008-02-08

      I just added a feature to the SVN code, if you compile MediaTomb with ffmpeg support you will be able to apply fourcc based transcoding settings to the transcoding profiles. This way you could say that you want to transcode only xvid AVI files but not divx or stuff like that.

       
    • Angel Garcia-Galan

      Please, can you post some config.xml lines to show how to do this?.
      I think It would be useful to many people (like me).  ;-)
      Thanks

       

Log in to post a comment.