Failed start. Suse (linux newbie)

Help
callidus
2007-07-02
2013-05-30
  • callidus

    callidus - 2007-07-02

    Well.

    I installed it, and everything worked. I connected to the server GUI through firefox, and started to add my sizeable music collection. As  this seemed to take a while, I left the room to take care of other business. Upon my return i found that the fuse hade blown (not a seldom event in this house). Fixed the fuse and started up again, but now all i get from mediatomb is:

    einarbrage:/home/einarb/Apps/twonky # mediatomb

    MediaTomb UPnP Server version 0.9.1 - http://mediatomb.cc/

    ===============================================================================
    Copyright 2005-2007 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2

    2007-07-02 15:29:01   ERROR: Could not create directory /root/.mediatomb : Permission denied

    I am logged in as root. What is causing this?

    Thanks in advance.

     
    • Jin

      Jin - 2007-07-02

      Hi,

      first of all: how did you start MediaTomb in the first place? did you use it as a system service? I would not suggest running MediaTomb as root.

      Good question about permisions, you could check the mode of /root/.mediatomb, see that it is writable, maybe try chmod u+rwX /root/.mediatomb

      If that still does not help you can simply wipe the ~/.mediatomb directory and let the server create it again (in this case you will also have to import your music collection again).

      I really don't know why the directory is suddenly not writeable, we do not do any chmod operations so I guess something went wrong when the system died.

       
    • callidus

      callidus - 2007-07-02

      I tried both your suggestion (to the best of my ability), and it came out like this:

      einarbrage:~ #  chmod u+rwX /root/.mediatomb
      chmod: cannot access `/root/.mediatomb': No such file or directory
      einarbrage:~ # dir
      total 48
      -rw------- 1 root root 2431 2007-07-02 15:04 .bash_history
      drwxr-xr-x 2 root root 4096 2006-11-25 22:49 bin
      drwx------ 3 root root 4096 2007-06-26 03:37 .config
      -rw-r--r-- 1 root root 1332 2005-11-23 17:06 .exrc
      drwxr-xr-x 2 root root 4096 2007-06-25 18:22 .fvwm
      drwx------ 2 root root 4096 2007-06-26 01:44 .gnupg
      drwxr-xr-x 2 root root 4096 2007-06-25 18:22 .kbd
      drwxr-xr-x 2 root root 4096 2007-07-02 15:06 .wapi
      -rw------- 1 root root   55 2007-07-02 15:09 .xauthd0qxMK
      -rw------- 1 root root   55 2007-06-26 00:46 .xauthEi52s0
      -rw------- 1 root root   55 2007-06-25 16:43 .xauthN2AyOp
      -rw------- 1 root root  111 2007-06-26 03:44 .Xauthority
      einarbrage:~ #                                     

      As far as i can see, there does not appear to be a ~/.mediatomb directory. This is quite puzzling.

       
    • callidus

      callidus - 2007-07-02

      QUOTE

      Jin:

      "first of all: how did you start MediaTomb in the first place? did you use it as a system service? I would not suggest running MediaTomb as root."

      I installed it while logged in as root. then simply wrote "mediatomb" in the console (can not remember if I was logged as root in the terminal). I i try to open mediatomb wwhile NOT logged in as root in the console, I get:

      MediaTomb UPnP Server version 0.9.1 - http://mediatomb.cc/

      ===============================================================================
      Copyright 2005-2007 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
      MediaTomb is free software, covered by the GNU General Public License version 2

      2007-07-02 16:22:37    INFO: Loading configuration from: /home/einarb/.mediatomb/config.xml
      2007-07-02 16:22:37   ERROR: could not open file /home/einarb/.mediatomb/config.xml : Operation not permitted
      einarb@einarbrage:~>.

      What should I do? Uninstall it and try again? Or does there seem to be some setting "residues" that probably won't go away with the uninstall and clutter subsequent re-installs? Bear with me here. I'm a newbie ;-)

       
    • Jin

      Jin - 2007-07-02

      ok, well - we try to create a directory in the users home ~/.mediatomb - we store the configuration and the database there.

      seems that in your case we fail to create that directory; must be something about your system..

      anyway, I would not run MediaTomb as root - it's a security risk; I would suggest that you try it as normal user or set it up
      as system service.

      if you still want to go on hacking the case above, you could try to mkdir ~/.mediatomb yourself and do a chmod a+rwX on it, I would not suggest doing that; as I already pointed out - running MediaTomb with root permissions is not a good idea.

       
    • Jin

      Jin - 2007-07-02

      doh... well, I never tried it on SuSE, but from what I see something weird is going on with permissions. For some reason the MediaTomb process is not allowed to access files in your home directory; I really have no idea why this would be happening.

      How did you install the package anyway, we do not provide rpm files for SuSE, did you compile it yourself?

       
    • callidus

      callidus - 2007-07-02

      I did a ./configure make make install kind of thing. If that's compiling, then yes.
      Upon inspection, there is no /home/einarb/.mediatomb directory, so even if access was permitted, it wouldn't find anything.
      What would you suggest I so to try and purge this installation of mediatomb completely from my computer? I'll try the suse specific forums also, of course.

      Thanks!

       
    • Jin

      Jin - 2007-07-02

      It's OK that the directory does not exist - it is created by MediaTomb at first time startup. However, for some reason that does not work for you.

      Let's try from the start:

      1. as a normal user, unpack the sources
      2. run configure: ./configure --prefix=/home/`whoami`/MediaTomb
      3. please paste me the configure summary, the one where it prints what libraries have been found and what not
      4. make
      5. make install

      now, make sure you do not have the .mediatomb directory in your home, and try to start the server:
      ~/MediaTomb/bin/mediatomb

      did it work now? it should :)

       

Log in to post a comment.