Anonymous - 2012-04-25

Hi there everyone.

I know there are already some threads on the subject of Toshiba Regza televisions and there is a lot of conflicting info some helpful, some not so.

But to get to the point, I still have not got it to play video, but audio and photographs is no problem, I can browse movies of all file types, but just get an error on playback..

I believe the problem must be in the transcode settings, so someone with a little more knowledge may be able to help with that.

I am installing on ubuntu server and using mysql for the database, you will have to edit the database settings to suit yourself.
but so far, this is what I have got….

Install VLC

sudo apt-get install vlc

install Mediatomb

sudo apt-get install mediatomb

then edit the config.xml so it is as below…..

<?xml version="1.0" encoding="UTF-8"?>
<config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd">
  <!--
     Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
     information on creating and using config.xml configration files.
    -->
  <server>
      <ui enabled="yes" show-tooltips="yes">
        <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>
      </ui>
    <name>mediatomb</name>
    <udn>uuid:757bd6cf-7b12-4a10-8beb-d96b9b632c8c</udn>
    <home>/home/username/.mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage>
      <sqlite3 enabled="no">
        <database-file>mediatomb.db</database-file>
      </sqlite3>
      <mysql enabled="yes">
        <host>localhost</host>
        <username>mediaserver</username>
        <database>mediaserver</database>
    <password>mediaserver</password>
      </mysql>
    </storage>
    <protocolInfo extend="yes"/>
    
    <custom-http-headers>
    <add header="X-User-Agent: redsonic"/>
    <add header="transferMode.dlna.org: Streaming"/>
    <add header="contentFeatures.dlna.org:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"/>
    </custom-http-headers>
    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    
   <extended-runtime-options>

        <ffmpegthumbnailer enabled="yes">
            <thumbnail-size>128</thumbnail-size>
        <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
        </ffmpegthumbnailer>
    <mark-played-items enabled="no" suppress-cds-updates="yes">
    <string mode="prepend">*</string>
    </mark-played-items>
  </extended-runtime-options>
</server>
   <filesystem-charset>UTF-8</filesystem-charset>
   <metadata-charset>UTF-8</metadata-charset>
   <playlist-charset>UTF-8</playlist-charset>
  <import hidden-files="no">
    <filesystem-charset>UTF-8</filesystem-charset>
    <metadata-charset>UTF-8</metadata-charset>
    <playlist-charset>UTF-8</playlist-charset>
    <scripting script-charset="UTF-8">
       <common-script>/usr/share/mediatomb/js/common.js</common-script>
       <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
        <virtual-layout type="builtin">
          <import-script>/usr/share/mediatomb/js/import.js</import-script>
          <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
            </virtual-layout>
        </scripting>
<mappings>
   <extension-mimetype ignore-unknown="no">
    <map from="mp3" to="audio/mpeg"/>
    <map from="ogg" to="application/ogg"/>
    <map from="asf" to="video/x-ms-asf"/>
    <map from="asx" to="video/x-ms-asf"/>
    <map from="wma" to="audio/x-ms-wma"/>
    <map from="wax" to="audio/x-ms-wax"/>
    <map from="wmv" to="video/x-ms-wmv"/>
    <map from="wvx" to="video/x-ms-wvx"/>
    <map from="wm" to="video/x-ms-wm"/>
    <map from="wmx" to="video/x-ms-wmx"/>
    <map from="m3u" to="audio/x-mpegurl"/>
    <map from="pls" to="audio/x-scpls"/>
    <map from="flv" to="video/x-flv"/>
    <map from="mkv" to="video/mpeg"/>
    <map from="m2ts" to="video/mpeg"/>
    <map from="avi" to="video/mpeg"/>
    <map from="mka" to="audio/x-matroska"/>
    <map from="mov" to="video/quicktime"/>
   </extension-mimetype>
<mimetype-upnpclass>
<map from="audio/*" to="object.item.audioItem.musicTrack"/>
<map from="video/*" to="object.item.videoItem"/>
<map from="image/*" to="object.item.imageItem"/>
<map from="application/ogg" to="object.item.audioItem.musicTrack"/>
</mimetype-upnpclass>
<mimetype-contenttype>
<treat mimetype="audio/mpeg" as="mp3"/>
<treat mimetype="application/ogg" as="ogg"/>
<treat mimetype="audio/x-flac" as="flac"/>
<treat mimetype="image/jpeg" as="jpg"/>
<treat mimetype="audio/x-mpegurl" as="playlist"/>
<treat mimetype="audio/x-scpls" as="playlist"/>
<treat mimetype="audio/x-wav" as="pcm"/>
<treat mimetype="audio/L16" as="pcm"/>
<treat mimetype="video/x-msvideo" as="avi"/>
<treat mimetype="video/mp4" as="mp4"/>
<treat mimetype="audio/mp4" as="mp4"/>
<treat mimetype="application/x-iso9660" as="dvd"/>
<treat mimetype="application/x-iso9660-image" as="dvd"/>
<treat mimetype="video/x-matroska" as="mkv"/>
<treat mimetype="audio/x-matroska" as="mka"/>
</mimetype-contenttype>
</mappings>
</import>
<transcoding enabled="yes">
    <mimetype-profile-mappings>
        <transcode mimetype="video/x-flv" using="vlcmpeg"/>
        <transcode mimetype="video/x-msvideo" using="vlcmpeg"/>
        <transcode mimetype="application/ogg" using="vlcmpeg"/>
        <transcode mimetype="application/ogg" using="oggflac2raw"/>
        <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
    </mimetype-profile-mappings>
        <profiles>
            <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
        </profile>
        <profile name="vlcmpeg" enabled="yes" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
                        <agent command="vlc" arguments="-I dummy %in --sout #transcode{vcodec=mp2v,vb=4096,fps=25,vfilter=canvas{width=720,height=576},acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>            
                        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
        </profile>
        </profiles>
        </transcoding>
</config>

as I say, I can brows through all the content, play music and view photographs, but no video…. please help !!