MediaTomb & Bravia W4500

1 2 3 > >> (Page 1 of 3)
  • Matjaz Ostroversnik

    Hi all,

    Sony Bravia xxW4500 supposed to be DLNA compliant. I've installed mediatomb server on Fedora 10 and tried to connect from tv set to the server. No luck.

    Server is running

    mediatomb 29913 mediatomb    5u  IPv4 235791      0t0  TCP *:50500 (LISTEN)
    mediatomb 29913 mediatomb    6u  IPv4 235792      0t0  UDP localhost.localdomain:43800
    mediatomb 29913 mediatomb    7u  IPv4 235793      0t0  UDP *:ssdp

    but tv does not recognize the server. When I run the diagnostics on tv set, I get properly recognized computer (ip, mac addrss, tcp port), but I can not connect.
    There are two messages:
    - The server is not supported.
    - The server does not support.     (there is no explanation what is not supported)

    Do you have some idea how to fix the problem, so that the server will be recognized?

    Thanks in advance


    • Jin

      Jin - 2008-12-26

      I'd call Sony support and ask why they think that being DLNA compliant automatically means to refuse to work with plain UPnP servers, after all - DLNA just sits on top of UPnP.

      We already went through a lot of pain with the PlayStation 3, we added various DLNA tags to enable support for this very troublesome device. Unfortunately, those extensions do not help with the Bravia TV.

      I have to say that MediaTomb is not DLNA compliant, we did add the extensions that were needed for the PS3, but otherwise we only implement the UPnP specification. Most devices (actually, devices from almost all other vendors, except Sony) are satisfied with UPnP.

      I can not really help you here, I do not have this TV so I can not debug the issue and to be honest - after all the troubles with the PS3 my motivation to solve another Sony riddle is quite low.

      Of course, if you decide to have a go at this and figure out what pieces of XML the TV is expecting, I can add it and I can also give you some hints on how to approach this issue. Basically it will come down to comparing XML from some working server to ours.

      Kind regards,

    • Matjaz Ostroversnik

      Happy New Year!!!

      Thanks for your answer.
      Next time I have to read "small print" before buging sony Stuff. :-(
      Do I undersand correct? Mediatomb works correct with PS3. If I buy PS3 and connect it with HDMI cable to W4500, I am able to play all videos, misic and picutures from PS3, even if this resources are available (through MediaTomb) from my linux server?

      Is my understanding correct?

      Best regards


    • Jin

      Jin - 2009-01-03

      Hi, thanks :) HNY to you too!

      Yes, although there are still some problems with the PS3 it works quite well - we had to add quite some things to support it. If I were you I would rather get a Popcorn Hour A-100 and not a PS3... it has a far better UPnP compatibility and plays almost everything you throw at it, including .mkv. The PS3 is very picky about codecs and often requires transcoding on particular formats... it can be a pain.

      Regarding the Bravia.. I got some useful logs from one of the Bravia users, maybe I will be able to figure out what it needs and add a couple of hacks to support it, let's see.

      Kind regards,

    • gggggg

      gggggg - 2009-04-07

      any new conclusions ?

      I'm having the same trouble with Sony X4500

    • aTc

      aTc - 2009-04-08

      Yes, vimacs on our IRC channel managed to get it working with his bravia tv.
      It's nowhere near complete though,and might only work on his tv.
      If you want to give it a try, join us on irc (details are on the mediatomb homepage).

      • gggggg

        gggggg - 2009-04-09

        Thanks for the info. Of course I'd like to try.
        I had a look at the homepage, but ..... How can I join ? What is the IRChannel ?
        Thanks in advance

      • gggggg

        gggggg - 2009-04-09

        I tried to connect via
        but was not successfull ... I think I need some advice ... regards from Austria

    • Jin

      Jin - 2009-04-09

      Sers ;)

      You need an IRC client, I suggest to try Pidgin which is free and which is available for both, Linux and Windows.

      Kind regards,

  • Jin

    Jin - 2010-01-27

    OK guys.. thanks to vimacs I added a little hack that is supposed to get the Bravia TV going. I know a second patch is needed to improve things regarding some video files, I still have to look into it. But at least basic support should be there. Having said that - I have no possibility to test it, so you will have to tell me if it worked.

    You need at least SVN revision 2057 and make sure to set <protocolInfo extend="yes"/> in your config.xml

    Let me know how it went :>

  • Jeremia

    Jeremia - 2010-03-17

    Hi guys,

    has anybody tried the Sony hack so far? Ich checked out the source yesterday (revision 2072 or something like this). After building and installing on my maschine, the tv finds the server but can't connect to it.
    Am I doing something wrong?

    Best regards


  • Anonymous - 2010-04-12

    Hi People.

    Faced the same problem - mediatomb does not know how to work with television Sony Bravia. Unfortunately the only option for me now is to use the HMS ( in wine ( It works, and works quite well on my Sony Bravia 40w5720. Playing about 90% movies / anime.

    I'd like to believe that developers implement support for the TV Sony.

  • Jeremia

    Jeremia - 2010-04-13


    there is another solution. Minidlna qorks quiet well with sony bravia but it is hasn't a lot of features. Because of this i want to use mediatomb. Are there any news for Sony televisions and mediatomb?

    Best regards


  • Jin

    Jin - 2010-04-13

    Well, there are basically two points:

    MediaTomb is a UPnP, not a DLNA server
    I do not have a Sony Bravia TV

    While the first point is only "somewhat" crucial - after all we do often add DLNA hacks, mostly for the PS3, it's still in issue. Full DLNA compliance is a lot of effort and since mostly Sony devices have the problems and the majority of others works just fine with plain UPnP, we do not have DLNA on top of our list.

    And the second thing - well, if you can debug hands-on, it's just faster and often the only possible way to get things solved. We can often work with wireshark logs and comparisons of captures, but it still takes quite some time to figure things out.

    If someone here would dedicate him/herself to helping with Bravia support - i.e. testing custom builds and providing logs upon my requests, we could probably get a little further.

  • Jeremia

    Jeremia - 2010-04-14

    Hi jin_eld,

    thanks for your reply. I'd like to support you with testing and providing logs. Just tell me what i should check out and which outputs you want.

    Best regards


  • Anonymous - 2010-04-14

    I'm so the same is ready to provide the necessary information, please send me detailed instructions. My e-mail is

  • Jin

    Jin - 2010-04-15

    OK guys… let's have a look then. I think the easiest thing would be, if you take a random server which you think works best with your TV and make a wireshark log for me (se FAQ regarding wireshar).

    Make sure to start the log before you even start the server, I want the whole thing right from the start.

    Now, regarding "what to log" - let's start with an mp3 file, so, start the wireshark capture, start the DLNA server of your choice, start the TV, browse to an mp3 file on your TV, press play, as soon as you hear music - stop the capture, save it in pcap format and email it to me (jin at mediatomb dot cc). Thanks.

  • Jeremia

    Jeremia - 2010-04-16

    Hi jin_eld,

    ok thanks. I'll look in more detail at the weekend.

    Best regards


  • Jin

    Jin - 2010-04-18

    Thanks for the logs, I'll need to decipher all the DLNA crap in there, I'll probably make a test version for you within the next few days.

  • clppr

    clppr - 2010-04-19

    I've also got a new BRAVIA TV, the TV diagnostics say "the server does not support dlna" when I run them.  I'd be happy to help in testing if needed.

  • Greg King

    Greg King - 2010-04-23

    I've got a sony bravia s5700 exhibiting the same problems. It picks up TwonkyMedia, Windows 7 Media Player, and PlayBack ok.

    I've looked at some packet captures and MediaTomb doesnt seem to answer the GetProtocolInfoResponse request (if I'm reading it right). 

    On the WMP trace, WMP responds with an XML document full of DLNA tags and mime and content types….

    Also, I noticed WMP HTTP OK responses have "Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0" whereas MediaTomb doesn't specify UPnP-Device-Host…

    Happy to help with packet captures and testing !

  • Greg King

    Greg King - 2010-04-24

    Oh, and I forgot to mention, runnning:
    - kubuntu 10.04
    - latest svn mediatomb
    - compiled with enable-protocolinfo-extension and enabled in config.xml

  • Jin

    Jin - 2010-04-25

    I do have all the info I need right now (i.e. in the logs), did not have the time yet to hack something up, might take a little.

  • Anonymous - 2010-04-27

    I have a patch with against current svn (r2102) which gives me working MPEG and M2TS support as well as mp3 support when using a Sony W5710 and a V5500. I would like to see how I can commit this to svn. If possible I would like to have it tested.

  • Jin

    Jin - 2010-04-27

    I see someone was faster than me :) Thanks, actually I'm happy you did it. Can't test it however, I (luckliy ;) do not have any Sony equipment.

    Maybe you could patch the released 0.12.1 version, do a make dist and put the tarball somewhere for others to test and also send me the patch?

1 2 3 > >> (Page 1 of 3)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks