setup & MySql

Help
Pongi
2006-10-26
2013-05-30
  • Pongi

    Pongi - 2006-10-26

    Hi, I followed the README instruction but I can't understand why there's a tomb-install script which fails if there's no sqlite installed - even if mysql is the preferred dbm of choice. I tried to make up the .mediatomb/* config files, but now I've a problem: I can't see the mediaserver from the network (I use the upnp tools from Intel), even if I did the route trick to eth0, and also I can't get the web UI working.

    This is my config:

    <config>
      <server>
        <ui enabled="yes"/>
        <port>54321</port>
        <name>JukeBox</name>
        <udn>[hidden]</udn>
        <home>/home/pongi/.mediatomb</home>
        <webroot>web</webroot>
        <storage driver="mysql">
          <host>localhost</host>
          <username>root</username>
          <password>[hidden]<password/>
          <database>mediatomb</database>
        </storage>
      </server>
      <import>
        <filesystem-charset>ISO-8859-1</filesystem-charset>
        <script>__DEFAULT_SCRIPT__</script>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="wmx" to="video/x-ms-wmx"/>
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
          </mimetype-upnpclass>
        </mappings>
        <library-options>
          <libexif>
            <auxdata>
              <add tag="EXIF_TAG_MODEL"/>
            </auxdata>
          </libexif>
        </library-options>
      </import>
    </config>

     
    • Jin

      Jin - 2006-10-26

      Hi,

      indeed - the tomb-install script is not an ideal solution and it is quite limited. I guess the script was not updated after MySQL support came in; anyway, for 0.9.0 the install script will be gone, the server will take care of the creation of the config.xml itself.

      So you have no sqlite3 at all? Else you could have created the config.xml using the script, and then simply adjust the storage section.

      Regarding the webroot entry - where are all the files located? Usually it is /usr/share/mediatomb/web - or did you copy all the files from there to your ~/.mediatomb/ directory? According to your config it will search for the files in ~/.mediatomb/web

      The files that are located there are not only important for the web UI, but also for UPnP - that would explain why Intel Tools do not list the server - the service descriptions can not be downloaded.

      Try this:
      http://www.deadlock.dhs.org/jin/config.xml

      Make sure that the paths like /usr/share/mediatomb/web match your installation.

      Does it work now?

      Greetings,
      Jin

       
    • Pongi

      Pongi - 2006-11-01

      yep, it worked. I didn't get the thing about files and webserver - I thought that the first run of mediatomb would have produced those files. Now I can see the devices, but still cannot play videos, but I didn't dig enough in helpfiles and docs to say it's not my fault. ;-)

       
    • Jin

      Jin - 2006-11-01

      Well, I think it would be best if you simply do a ./configure && make && make install, then run
      tomb-install and then edit the config.xml which will be created by tomb-install and setup mysql storage.

      What distro are you using? Can't you take the precompiled RPM packages?

      We are doing our best to get the 0.9.0 out as soon as possible, let's hope it will make things easier.

      Greetings,
      Jin

       

Log in to post a comment.