Missing already installed modules

Help
2011-04-01
2013-05-30
  • Piotr Mackowiak

    Piotr Mackowiak - 2011-04-01

    After printing config of MT i got such result:

    # mediatomb -compile-info

    MediaTomb UPnP Server version 0.12.1 - http://mediatomb.cc/

    ===============================================================================
    Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2

    Compile info:

            host:                   i586-mandriva-linux-gnu
            sqlite3:                yes
            mysql:                  missing
            libjs:                  yes
            libmagic:               yes
            inotify:                yes
            libexif:                yes
            id3lib:                 disabled
            taglib:                 yes
            ffmpeg                  yes
            libmp4v2:               missing
            external transcoding:   yes
            curl:                   yes
            YouTube:                yes
            libextractor            disabled
            db-autocreate:          yes
            debug log:              yes
            protocol info extension:yes
            ffmpegthumbnailer:      missing
            lastfmlib:              missing
            data directory:         /usr/share/mediatomb

    So some modules are assumed as "missing"
    So I check about existing of this modules in my system. All modulex exept lastfmlib are present in the system. Results of checking:

    # urpmi -a libmp4v2
    Pakiet libmp4v2_1-1.9.1-2mdv2010.1.i586, libmp4v2-devel-1.9.1-2mdv2010.1.i586, libmp4v2-utils-1.9.1-2mdv2010.1.i586, libmp4v2_1-1.9.1-2mdv2010.1.i586, libmp4v2-devel-1.9.1-2mdv2010.1.i586, libmp4v2-utils-1.9.1-2mdv2010.1.i586 jest już zainstalowany w systemie
    (sorry it is in Polish but it stands that all listet above modules are already present!
    An others:
    # urpmi ffmpegthumbnailer
    Pakiet ffmpegthumbnailer-2.0.2-1mdv2010.1.i586 jest już zainstalowany w systemie
    So this module is present in system too.

    Can anybody tell me why this modules "mediatomb -compile-info" assume to be "missing"?

    Can anybody help me?

     
  • BT

    BT - 2011-04-01

    I'm certain but I think the -compile-info options only shows what options MediaTomb was built with, not whether those libraries are installed or not. So in your case those libraries were missing during build time. I suggest you contact the MediaTomb package maintainer for your distribution. Alternatively you could build MediaTomb yourself.

     
  • Piotr Mackowiak

    Piotr Mackowiak - 2011-04-01

    Yehhh. I installed MediaTomb by simply using "urpmi mediatomb" command on my Linux Mandriva based server. So the binaries was taken from Mandriva repository "as is". So propbably the problem is.

     

Log in to post a comment.