Mediatomb broken on Fedora Core 18

  • David

    David - 2013-02-27

    I recently upgraded to FC18 and I'm finding that mediatomb is broken.   After a bunch of tweaking I am able to browse directories from the client and see files.  When I select a file (video file) to play the client is unable to play the file.  It appears the media stream is not established but the debugging messages do not provide any details on the problem.  Does anyone have this working on FC18?

  • tday981

    tday981 - 2013-03-04

    I have the same problem.  When I try and reach the web interface, all I get is a login prompt but I have not set a password.  Typically this has indicated that there was an issue in using the database, I use mysql, but that shouldn't be the case since I can login and read the db/tables just find from a shell.  I've also tried using sqlite as the db, but I still have the same results.  I'm at a loss and agree that the debug logs are of no help.

  • tday981

    tday981 - 2013-03-04

    just decided to downgrade, and ui functionality seems to be back "yum downgrade mediatomb".

  • Jin

    Jin - 2013-03-04

    Not being able to reach the UI usually means that either the server port has changed, while you are trying to connect to the old port, or that the server is not running.

    You should check the server log, unfortunately I do not remember where the system wide log on F18 goes, maybe try /var/log/mediatomb or check the init scripts (or is it systemd now?) what the parameter for the log file is.

  • Mat L

    Mat L - 2013-03-05

    I have tested mediatomb on my system too. I was really confused when it stopped working after the upgrade, since I had changed nothing in the configuration. I downgraded mediatomb and the UI showed up again without me making any changes to the config, once I had completed the downgrade. The one that works is mediatomb 0.12.1-21.fc18 and the broken one was 0.12.1-23.fc18. I spent two days trying to figure out what was going on, but the log file said everything was loaded, except the port I specified \\\"50500\\\" was never chosen as the actual port to use. Instead it used 49152 and route had a message \\\"SIOCADDRT: File exists\\\". I would always be presented with the login screen where mediatomb prompts for a username and password that never works. I am using sqlite as the database.
    I would post some of the logs, but sourceforge won't let me. The only difference was in the working one it actually used port 50500 and the non working one used the default.

  • Anonymous - 2013-03-11

    Looking at the debug output it looks like it's trying to read the xml values from config.xml before loaded the file and is using default values since there are no values to read.  I've got a log file with debug output of mediatomb trying to launch with the current version, but the forums won't let me upload it.  Citing spam.

  • David

    David - 2013-03-15

    I was unable to get it to work so I went back to FC17.  Then FC17 updated to rpm 0.12.1-23 and the same breakages appeared in FC17.  Yum downgrading to rpm 0.12.1-16 got everything back to a working state on FC17.

    It looks like the maintainer has identified the problems (or at least some of them) and produced an rpm 0.12.1-24 for Fedora Rawhide.  But that version of the rpm is not yet available for FC17 or FC18 (according to

    When a 0.12.1-24 is available for FC17 or FC18 I'll test it out and let you know what I find.

  • David

    David - 2013-04-05

    Just for fun I installed the 0.12.1-24 FC19 RPM on my FC18 system.  It installed fine and the port recognition problem was resolved. 

    However the initial problem persisted - I am unable to play any media files.  With debug messaging enabled, there are still no debug messages that point toward a solution.  Is anyone else able to get media streams working with mediatomb on FC18?

  • Mat L

    Mat L - 2013-04-25

    The latest mediatomb update works great :)

  • David

    David - 2013-04-30

    Confirmed.  0.12.1-26 FC18 RPM works well on my FC18 system.  The server is visible on the defined ports and videos play as expected.  Thanks for the support.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks